website doens't display well

RESOLVED FIXED in mozilla1.7beta

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: jon, Unassigned)

Tracking

Trunk
mozilla1.7beta
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031104 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031104 Camino/0.7+

sure, the html source is filled with a bunch of microsoft ****, but IE 5.2.3 on
OSX 10.3 at least kinda displays the text on the page...

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
mozilla bug, happens there too
Assignee: pinkerton → general
Status: UNCONFIRMED → NEW
Component: General → Browser-General
Ever confirmed: true
Product: Camino → Browser
QA Contact: general
Version: unspecified → Trunk

Comment 2

15 years ago
I would guess that this is a Tech Evangelism bug. It isn't surprising that it
renders alright in IE, since as you said it makes extensive use of MS-specific
code which is gibberish to any other browser.
The source of the page has all the content carefully commented out.  IE's parser
is purposefully broken to ignore the exact kind of comments that page uses.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
what is invalid about the commented code?

i mean, camino/mozilla's 'view source' function properly color highlights
everything and the text in the page is in proper html markup...

i think that mozilla/camino should at least display something more than what it
currently does.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
> what is invalid about the commented code?

Nothing.  Just most of the content on the page is commented out from mozilla's
point of view.
Marking invalid again.  There is nothing we can do to support this sort of
"HTML" short of completely breaking our HTML comment parsing.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 7

15 years ago
Actually, this is a dupe of bug 112015.
Just remove the "position:relative" from the outer <span> to make the page work.

Comment 8

15 years ago
I.e.: type
  javascript:document.getElementsByTagName("span")[0].style.position="static",
void 0
into the URL bar.
Oh, I see.  I'd missed that part... yay, "word-HTML".  Reopening.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Would probably be fixed by bug 135082
Depends on: 135082

Comment 11

15 years ago
FIXED by roc with bug 235778.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7beta
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.