Problem reopening several bugs at once

RESOLVED DUPLICATE of bug 95430

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 95430
15 years ago
6 years ago

People

(Reporter: Gerard Beekmans, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030613 Galeon/1.3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030613 Galeon/1.3.5

I query our list of resolved 'LATER' bugs, and select the ones I want to reopen.
I go to the bottom of the form and select the "Reopen bugs" radio button and
click on "Commit". I get a software error back (more details provided below in
this file bug form)

Reproducible: Always

Steps to Reproduce:
1. Go to query page
2. Select from Status: RESOLVED
3. Select from Resolution: LATER
4. Run the query
5. In result screen, click on "Change Several Bugs at Once"
6. Select bugs to reopen
7. Select "Reopen bugs" radiobutton
8. Click on "Commit" button

Actual Results:  
The following output is shown:

Bug processed
Content-type: text/html

Software error:

SELECT resolution FROM bugs WHERE bug_id = : You have an error in your SQL
syntax.  Check the manual that corresponds to your MySQL server version for the
right syntax to use near '' at line 1 at globals.pl line 276.

For help, please send mail to the webmaster (server-admin@linuxfromscratch.org),
giving this error message and the time and date of the error. 


Expected Results:  
It should have reopened the selected bugs.

I tracked the problem to line 658 in process_bug.cgi. The block contains:

    /^reopen$/  && CheckonComment( "reopen" ) && do {
                SendSQL("SELECT resolution FROM bugs WHERE bug_id = $::FORM{'id'}");

-----

$::FORM{'id'} doesn't contain anything at this point. The scalar @idlist does
contain the list of bugs I selected. Maybe there is supposed to be a foreach
loop somewhere?
what version of Bugzilla?
(Reporter)

Comment 2

15 years ago
Sorry, I thought I entered that. Version is 2.16.3
This was fixed in 2.17.1.  The patch on the original bug does *not* work on
2.16.4 (I just tried it).  However, it did port easily.  I'll post a patch
against the 2.16 branch on that bug shortly.

*** This bug has been marked as a duplicate of 95430 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.