Only one of two identical SPAM get filtered

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Andrew Stephen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

When two identical SPAM arrive in the inbox using IMAP with Move incoming junk
to "other folder" configured only the first of the two get marked as junk and moved.

Reproducible: Always

Steps to Reproduce:
1.  Wait for incoming identical SPAM (common with Swen worm and derivatives)
2.  ...
3.  Profit!

Actual Results:  
The first of the two messages gets marked as junk and moved to my spam folder. 
The second is not marked as junk and remains in my inbox.

Expected Results:  
Mark both incoming identical email as junk and move both to spam folder

Comment 1

14 years ago
Marking worksforme since a lot of spam filter code has changed since TB 0.3.
Reporter, please reopen if you still see this.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 2

12 years ago
Thunderbird version 1.5 (20051201); Mac OS 10.3.9

I have seen this behaviour all through Thunderbird 1.0.x and have now reproduced it in 1.5rc2.

Steps to Reproduce:
1. For a given email account on a server which supports both POP and IMAP, set up both an IMAP and a POP account in Thunderbird.

Actual Results:
On occasion a message will be marked as spam in one of Thunderbird's accounts but not in the other.

Expected Results:
Identical message downloaded from the server should be filtered consistently in Thunderbird's POP and IMAP accounts.

Additional Notes:
IMAP and POP accounts are set for SSL access with no secure authentication. Server address in TB is different, but the two addresses resolve to the same IP and server. The training.dat file was reset on upgrade to 15.rc2. Under previous versions of TB, this behaviour was observed on two different servers.

Comment 3

12 years ago
See Bug 284308 Comment #6 for some statistics which show the spam filter performing inconsistently on identical messages.

I believe that this bug is present in version 1.5 (20051201). Could someone with the appropriate privs please reopen it?
You need to log in before you can comment on or make changes to this bug.