If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multiple word font name (Lucida Sans Unicode) crashes Firebird GTK2/XFT build

RESOLVED EXPIRED

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED EXPIRED
14 years ago
9 years ago

People

(Reporter: Marecandja, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: look at comment 7 for a good bug description, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Firebird crashs when trying to load the given page from the given URL. It
doesn't write/send any error message. Nothing.

Reproducible: Always

Steps to Reproduce:
1. Click on the link 'Extensions' on the home page of Firebird
Actual Results:  
Firebird contacts with the server texturizer.net and then closes itself without
any message.

Comment 1

14 years ago
WFM Firebird 0.7 Windows 2003

Comment 2

14 years ago
Can you do a clean install with a fresh profile and disable all extensions?

Comment 3

14 years ago
Works for me on 20031109 build on WinXP. 
Please try to reinstall, create a fresh profile (delete the old .phoenix-folder)
and try iz without any additional extensions and themes.
QA Contact: bugzilla
(Reporter)

Comment 4

14 years ago
Please all note that the problem is reported for Linux, not Windows!

I will try to delete the phoenix folder and try again. But I have no extensions
installed nor any themes.
(Reporter)

Comment 5

14 years ago
Did delete phoenix folder and retry without success...
(Reporter)

Comment 6

14 years ago
I have isolated the problem on the GTK2/XFT version for Linux.

The problem does not occur when using the other version.
(Reporter)

Comment 7

14 years ago
I have finally pinpointed the cause of this bug.

It is (at least in this case) due to the font named 'lucida sans unicode' which
is a composed name (multiple words). This makes Firebird crashes.

I have tried with quotes " or ' . Same result. It just won't take it.

This should be fixed quickly now. Could you confirm.

Thanks
Keywords: crash, css1, fonts

Comment 8

14 years ago
Over to Browser - GFX: GTK
Please look at comment 7, when trying to confirm this issue.
Assignee: blake → blizzard
Component: General → GFX: Gtk
Keywords: css1, fonts
Product: Firebird → Browser
QA Contact: bugzilla → ian
Summary: crash when trying to surf into that web page → Multiple word font name (Lucida Sans Unicode) crashes Firebird GTK2/XFT build
Whiteboard: look at comment 7 for a good bug description
Version: unspecified → Trunk
(Assignee)

Comment 9

14 years ago
This is working fine on my system.  Odds are it's a dup of one of the mostfreq
xft bugs.  What distro and version are you running firebird on?
(Reporter)

Comment 10

14 years ago
Linux 2.4.22 on RedHat 9 with XFree86 Version 4.3.0

Comment 11

14 years ago
Cannot duplicate here.
Linux kernel 2.6.1 Glibc<CVS> NPTL GTK+2 XFT
CVS 0.8+ FireBird as of Jan 21, 04

Comment 12

14 years ago
reporter, can you do the following and post the result here?

$ fc-list 'Lucida Sans Unicode' file family


(Reporter)

Comment 13

14 years ago
[flop@omega flop]$ fc-list 'Lucida Sans Unicode' file family
/usr/share/fonts/default/TrueType/l_10646.ttf: Lucida Sans Unicode

Comment 14

13 years ago
*** Bug 252535 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.