Right-click on Bookmark Toolbar Folder menu items causes buttons to stay pressed

VERIFIED DUPLICATE of bug 210910

Status

()

Firefox
Bookmarks & History
--
critical
VERIFIED DUPLICATE of bug 210910
15 years ago
12 years ago

People

(Reporter: Dain Anderson, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031109 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031109 Firebird/0.7+

With the Bookmark Toolbar Folder activated, and having subfolder(s) with links,
if you click on any of the folders, right click any of their content links, and
then click anywhere outside of the context menu, it causes the button (that has
the folder icon) to stay "pressed".

This also causes all typing to cease. You cannot type or use Control commands
(CTRL-T, for example) unless you close and re-open Firebird.

Reproducible: Always

Steps to Reproduce:
1. Activate the Bookmark Toolbar Folder (Make sure the Bookmark Toolbar Folder
has sub-folders containing links)
2. Click on any of the folders in the toolbar
3. While the folder contents are expanded, right-click on one of the links
4. Without clicking any right-click menu options, click somewhere else, such as
the browser title bar.
5. The button representing the menu folder is now depressed
6. Try hitting Control-T (new tab), or try typing in the location bar

Actual Results:  
The Bookmark Toolbar Folder menu button stays pressed and all typing is prohibited

Expected Results:  
Button should return to its "normal" state and typing functionality should return

I've attached a screenshot of the actual steps to reproduce this. I've listed
this as "critical" because you cannot type once this happens, essentially
hanging it.
(Reporter)

Comment 1

15 years ago
Created attachment 135181 [details]
Screenshot of issue

Comment 2

15 years ago
-> Firebird
(I can´t reproduce this using mozilla)
-> Firebird
Assignee: hyatt → p_ch
Component: XP Toolkit/Widgets: Menus → Bookmarks
Product: Browser → Firebird
QA Contact: shrir → mpconnor
Version: Trunk → unspecified

*** This bug has been marked as a duplicate of 210910 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
verified.
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.