If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

width 100% doesn't layout well if all the tables content wasn't received initially

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: khalid, Unassigned)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

In http://www.abrag.net/writers (and others)  the layout goes wrong if the
connection is slightly slow to the extent that not all the td's of the main
table are received initially, so only the received td's take the 100% width and
the third td goes out of the window horizontally, it maybe hard to explain, but
it may be because of Gecko's nature of rendering before all the content is received.

In the page I sent you there are three td's in the main table, if the connection
is slow that only two of them are received initially, these two td's get the
100% width and the third td goes completely out of the window, a scroll bar is
shown but this is not the correct behaviour.

In another page like (http://kxparse.berlios.de, width 100% as well) when the
vertical scrollbar appears it doesn't truncate the content, but the content goes
under it, and a horizonital scrollbar appears, and that's because the content
received initially (in the slow connection) is not enough for a vertical
scrollbar to appear, but when the layout engine receives more content, it has to
show the vertical scrollbar, and this behaviour appears.

I hope you understood me :-)

Thanx

Reproducible: Always

Steps to Reproduce:
1.Limit the speed of your connection to a slow rate.
2.open http://www.abrag.net/writers
3.

Actual Results:  
the page given shows a main table (100% width) containting three <td>'s only two
<td>'s take the 100% width and the third goes out and a horizonital scrollbar
appears.

Expected Results:  
the three <td>'s should have shared the 100% width, and no horizonital scrollbar
should have appeared (both Konqueror and IE 5,6 do that, don't know about Opera)
maybe because IE doesn't render before receiving the full content.

This happens on Linux, firebird on windows didn't do the same that's because
windows runs my modem better and gives a better connection speed (expectedly),
but I believe the layout engine should do the right thing whatever the
connection speed (i.e resizing the current content so the window fits the newly
received content).
(Reporter)

Comment 1

14 years ago
you'd better visit http://www.abrag.net/writers/browse.php, there's more content
in the middle <td> there, so the behaviour is likely to happen there more.
a testcase using hyatt's trick would rock here.
Keywords: qawanted
(Reporter)

Comment 3

14 years ago
Excuese me, but what's hyatt's trick ? :-)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208

This happens all the time on certain pages, e.g. Yahoo! Mail.  It is extremely
irritating in that you have to scroll even to see the folder names most of the
time.  Give it a try :)

P.S.: It happens more often if you have it setup to collect POP mail.
*** Bug 231774 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
hyatts trick is  at
http://weblogs.mozillazine.org/hyatt/archives/2003_08.html#003963

Comment 7

13 years ago
The URL no longer works. Is there another page that exhibits this behaviour?

Comment 8

13 years ago
No response to Jason's request from about half a year ago. I even checked
web.archive.org but they do not have the page either.  kxparse.berlios.de looks
fine to me.

Time to close this bug?

Comment 9

13 years ago
Yup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.