Add a Remote Download Manager functionality

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
15 years ago
9 years ago

People

(Reporter: coffeebreaks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024 Debian/1.5-2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024 Debian/1.5-2

My idea is to add a 'remote download manager' feature to mozilla navigator.

I want to be able to surf from one machine, and trigger the download
transparently from another machine. Imagine I have a server at home, I find
something interesting on the web when surfing from a friend's place or work. I
plug my mozilla download manager to my server's remote download manager in some
way, start downloading the stuff, and when I arrive home, it's there for me. 

The server functionality could be either be custom built, reuse an existing
application (such as protozilla) be based on the GRE...

There are many things to do to achieve this implementation, the most difficult
ones (for me) are deciding on an API for the client/server communication, the
other being to plug it nicely into the default download manager. SOAP or similar
seems well indicated for the communication, but perhaps others should come up
with ideas.

I will perhaps have some time early next year. If I do, I am willing to invest
it in implementing/prototyping such feature if I can come up with some help from
the community, at least for the design stage, where my knowledge of mozilla is
close to null.

So the first point would be to discuss how such a feature would be to implement,
which points would be hard. What does it take to make it a module, etc...
The client/server download manager protocol must be decided. Then we can we can
start making prototypes.

Reproducible: Always

Steps to Reproduce:
Supporting external Downloadmanagers should be enough. There is a win32 bug
about that (with a patch)...

Comment 2

15 years ago
Do you have a link, Matti?

Are there any external downloadmanagers that do it Right?

How do they work?
Product: Browser → Seamonkey

Comment 3

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

9 years ago
The SeaMonkey team has no interest in working in this ourselves, but feel free to create an add-on for SeaMonkey 2 to do it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.