Mozilla crashes if any DocumentLoadListener is registered in DOMAccessor

VERIFIED FIXED

Status

Core Graveyard
Java APIs for DOM
P3
critical
VERIFIED FIXED
18 years ago
6 years ago

People

(Reporter: Michail Romanov, Assigned: Akhil Arora)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description:
After registering DocumentLoadListener in DOMAccessor Mozilla
often crashes in nsJavaDOMImpl::OnStartURLLoad(...) method
in java/dom/nsJavaDOMImpl.cpp file on the line number 359 (see below)
because contentType variable is NULL (actually crashes
NewStringUTF(NULL)). This happens because in some
implementations of nsIChannel interface GetContentType(..) method
returns NULL as the result (particulary PlaceholderChannel class in
rdf/content/src/nsXULDocument.cpp file).

356   char* contentType = (char*) "";
357   if (channel)
358       channel->GetContentType(&contentType);
359   jstring jContentType = env->NewStringUTF(contentType);

Steps to Reproduce:
1) Register DocumentLoadListener in DOMAccessor
2) Try to load any new document

Actual Results:
Mozilla crashes.

Expected Results:
statusURLLoad method of the registered DocumentLoadListener
should be called

Build Date & Platform Bug Found:
12/23/99 NT4.0

Additional Builds and Platforms Tested On:

Additional Information:
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

18 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Comment 2

18 years ago
the bug is fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
Marking verified per programmer comments
Status: RESOLVED → VERIFIED
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.