Mozilla hangs when submitting a form with multiple select element with style: width=0 and height=0.

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Mikko Irjala, Assigned: roc)

Tracking

({hang, testcase})

Trunk
x86
All
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Summary says it all. I will attach an HTML testcase that reproduces this problem.


Reproducible: Always

Steps to Reproduce:
1. View the HTML- testcase.
2.
3.




This "feature" appeared on Mozilla 1.4.
Mozilla 1.3 does not have this problem!
(Reporter)

Comment 1

14 years ago
Created attachment 135249 [details]
html testcase

Updated

14 years ago
Severity: normal → critical
Keywords: hang
Confirmed, current CVS build, Linux. Set NSPR_LOG_MODULES=all:5 and got no
useful output.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Comment 3

14 years ago
I see this too, it behaves much like bug 222503 (infinite loop of calls to
nsBlockFrame::Reflow).
Assignee: form-submission → other
Component: HTML: Form Submission → Layout
Depends on: 222503
Keywords: testcase
QA Contact: ian

Comment 4

14 years ago
Created attachment 135288 [details]
Testcase #2

Make the window width very small (so it clips the form control) and then make
it
wider again.  Do this a couple of times and Mozilla hangs at ~100% CPU.
Looks like scrollbar attribute setting to me (in the debugger).
Urk. I'll take this.
Assignee: other → roc

Comment 7

14 years ago
WFM, 2004-08-07-06 trunk Linux

Comment 8

14 years ago
WFM, 2004-08-06-07 trunk Windows XP

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.