Changing Style distorts rendering (involves position:absolute)

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: raccettura, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
I'm attaching 3 images.

When visiting our beloved Asa's blog, he's setup multiple styles to accomidate
his diverse audience of Mozilla lovers.

If you switch from Default, to "Old Style", then back to Default, you will see
some odd rendering of the links.

Refreshing will resolve this.

I've seen this on the mac as well.

Images forcoming.
(Reporter)

Comment 1

15 years ago
Created attachment 135255 [details]
Before
(Reporter)

Comment 2

15 years ago
Created attachment 135256 [details]
Changing the Stylesheet
(Reporter)

Comment 3

15 years ago
Created attachment 135257 [details]
Back to the original (default)... see bug
(Reporter)

Comment 4

15 years ago
CC: Asa
(Reporter)

Comment 5

15 years ago
Forgot:  Saw this on 1.6a.  Tested today again on 1.5.
A minimal testcase would be great.
Whiteboard: DUPEME

Comment 7

15 years ago
Created attachment 136211 [details]
testcase

This .zip testcase is pretty small, but it could probably be made smaller.

There are two problems that seem linked:
A) The second div is misplaced when you switch back.
B) The links are the wrong size when you switch back.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Changing Style distorts rendering → Changing Style distorts rendering (involves position:absolute)
Attachment #136211 - Attachment mime type: application/octet-stream → application/zip
Fixed by checkin for bug 170644.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.