OS/2 SYS3183 in mozjs.dll after one successful execution

RESOLVED DUPLICATE of bug 224487

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 224487
15 years ago
14 years ago

People

(Reporter: Wild Willy Kredentser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.6a) Gecko/20031103
Build Identifier: ftp://mozilla.isc.org/pub/mozilla.org/mozilla/nightly/latest/mozilla-os2.zip (2003/11/10)

Although I am reporting this for last night's build, I've actually seen this in
the past 3 nightly builds, and I waited to see if it was going to get fixed on
its own before I reported it.  This is with the OS/2 nightly build.

After executing sucessfully once, it traps with a SYS3183 on every subsequent
execution.

Reproducible: Always

Steps to Reproduce:
1. Open browser.
2. Scroll through all preferences, changing none, just looking at them.
3. Close browser.
4. Attempt to open browser again.
Actual Results:  
Gets SYS3183 every time.

Expected Results:  
It should have just opened again.

I'm classifying this as critical because the wording of that severity includes
the words, "Mozilla crashes." which is what is happening.  But the 1.6 Alpha is
working just fine for me, so from that point of view, this isn't critical.

I also noticed that in the Preferences -> Advanced -> Scripts & Plug-ins, the 
options for "Create or change cookies"  & "Read cookies" are missing.  This may
be intentional.  I have no way of knowing.  But that is something I noticed that
is different from 1.6a (and all previous versions of Mozilla that I've used). 
That may or may not be relevant to this problem.

Comment 1

15 years ago
Setting operating system to OS/2.
OS: other → OS/2

Comment 2

15 years ago
workaround in bug 224487

*** This bug has been marked as a duplicate of 224487 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Hmmm........  After reading the other Bug, I'm not surprised I didn't find it
when I searched before creating this one.  And I --> DID <-- search first in the
hopes I wasn't creating a duplicate.  Oh well.......

Thanks for adding me to the CC: list of the other bug.  I'll be following that
one closely.

Comment 4

15 years ago
Willy, OS/2 bug searches are best started on the link "Current Open Warpzilla
bugs" on http://www.mozilla.org/ports/os2/. Work from the bottom up. If that
doesn't get you what you're looking for, either it's not OS/2-only, or you
really are filing a new bug.

CC the person filing a dupe is a Bugzilla automatic thing.
(Reporter)

Comment 5

15 years ago
Thanks for the URL.  I'll keep it in mind.  But even if I had used it,  I would
NEVER have looked at Bug 224487 based on its appearance in a search results
list.  Its short description is SO esoteric that I would not have recognized
from that that it was even related to my problem.  The short description of Bug
224487 is in programmer-speak whereas I'm a user & my short description covers
what a user actually sees.  Only after reading about a screenload down in Bug
224487 did I recognize that it described my problem.  I saw a trap.  That's in
my Summary line.  The other Summary line talks about clobbering FPU.  It took me
a moment to even figure out what FPU means.  No, I'd have filed this one anyway.

I guess that's the danger of letting "dumb" users even a little bit in on a
development project.  I'm sure this isn't the first time it's happened & it
probably won't be the last.  Plus I'm just beginning to get comfortable with
Bugzilla so as my skills improve, my filing of duplicates should stop.

Comment 6

15 years ago
Click on "View Bug Activity" in my bug and you'll see that the programmers
changed my summary to add what you saw as obfuscation. I found the workaround
before even filing the bug. I knew that if it could run once, it could run again
by finding whatever running it changed, then undoing that.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.