Closed Bug 225375 Opened 16 years ago Closed 16 years ago

Full boolean message filters

Categories

(MailNews Core :: Filters, enhancement)

1.0 Branch
PowerPC
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 59821

People

(Reporter: mozilla02, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007

At the moment, a message filter can be setup with a large number of criteria.
The problem is that all of the criteria in a specific filter can only be AND'd
or OR'd together. You cannot specify something like:

  ( A || B ) && C

This is something I would like to be able to do. 

What would be even better is if in the future RPN boolean expressions could be
supported, eliminating the need to specify parenthesis.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
can someone dupe this? 
Assignee: mscott → sspitzer
Component: Mail Window Front End → Filters
Product: Thunderbird → MailNews
QA Contact: laurel
Version: unspecified → 1.0 Branch

*** This bug has been marked as a duplicate of 59821 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.