Closed Bug 22539 Opened 20 years ago Closed 20 years ago

Javascript error on arrow keys after revisiting a page

Categories

(SeaMonkey :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 23401

People

(Reporter: escowles, Unassigned)

Details

If you return to a page, the cursor keys will not scroll properly.  Instead,
they will generate the following error message:

     JavaScript Error: TypeError: controller has no properties

To reproduce:

1. Start mozilla with the file named example.html with the following contents:

    <html><body><a href="example.html">link to itself</a>
    <hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr><hr>
    <hr><hr><hr><hr><hr><hr>Something to scroll down to</body></html>

2. Click on the link, which loads the same page again.
3. Click anywhere in the main window to give it focus.
4. Up or down cursor keys give the error message instead of scrolling.
Summary: Javascript error on cursor after revisiting a page → Javascript error on arrow keys after revisiting a page
Changing summary from "cursor" to "arrow keys"
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 23401 ***
Verified dupe of 23401
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.