".txt" erroneously appended to some filenames when downloading

RESOLVED DUPLICATE of bug 213877

Status

Core Graveyard
File Handling
--
minor
RESOLVED DUPLICATE of bug 213877
14 years ago
a year ago

People

(Reporter: jeevesn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020618
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020618

When downloading text files that are not somehow known to Mozilla, the extension
".txt" is erroneously appended. The problem did not occur with .tex files
(source for a TeX or LaTeX document) but does occur with .sty files (macro code
files for TeX or LaTeX). I have seen this happen with other files as well, plus
files that have no extension. This may be useful behavior on a Windows platform,
but not on Unix.

Reproducible: Always

Steps to Reproduce:
1.Right-click a link to a non-HTML file of a type not registered in Mozilla
2.Choose Save Link Target As...
3.

Actual Results:  
For a "filename.sty" file  (for example), the default filename is
"filename.sty.txt". For a file with no extension, you get something like
"MAKEFILE.txt".

Expected Results:  
Not append ".txt".

Bug probably depends on file types registered to Mozilla, but I imagine most
Unix users don't need ".txt" appended to filenames under any circumstances.

*** This bug has been marked as a duplicate of 213877 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.