reloading a pdf file using external viewer gives stale version.(even after restart)

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Joshua Goldberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When revising a pdf file (I was using latex on a unix machine), reload or even
restarting Firebird don't let me see the changes.  The only fix is to manually
clear the cache in Tools-Preferences-Privacy-Cache-Clear*  I had associated
gsview with application/pdf, but I also tried Acroread.


(* which I didn't find the first couple of times I looked for, by the way.  It
wasn't obvious to look under Privacy.  But that's not what I'm here to report)

Reproducible: Always

Steps to Reproduce:
0. override the acrobat plugin.  (This works with either Acrobat OR gsview as
the associated program.)
1. load a pdf you can modify
2. save a new version
3. reload

Actual Results:  
see the old version

Expected Results:  
refreshed and shown the new version

Comment 1

14 years ago
Reporter, try setting 'browser.cache.check_doc_frequency' to 1 in about:config.

Comment 2

14 years ago
This WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040312 Firefox/0.8.0+ (using default settings). Unless you can reproduce
this in a newer build, I'm going to mark this as WFM in a few days.
Assignee: firefox → bugs
QA Contact: aebrahim

Comment 3

14 years ago
I'm marking this as WFM based on age of reporter's product, the fact that I've
been not able to reproduce this problem in either a 2004-03-12 build or a
2004-03-17 build, and that the reporter hasn't replied to any questions. We
can't (in general) fix a problem we can't reproduce.

Marking WORKSFORME. Reopen if you can reproduce with a current nightly build and
a clean profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.