Mouse wheel scroll speed inconsistent and "accelerated"

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: John Flynn, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

I've noticed that there is an annoying "acceleration" effect in scrolling with
the mouse wheel in Thunderbird, when there are a large number of messages in a
newsgroup. This makes it difficult to browse messages, because if I turn the
mouse wheel faster than "very slow", it starts scrolling pages at a time and I
lose my place.

I can't find any options for mouse-wheel behavior in the preferences.

Reproducible: Always

Steps to Reproduce:
1.Access a newsgroup with hundreds of messages.
2.Turn mouse wheel slowly in the messages pane, note scroll amount per "click"
of wheel.
3.Turn mouse wheel faster. Note scroll amount increases exponentially with speed
of mouse wheel rotation.

Actual Results:  
Scroll amount increases too quickly with mouse wheel speed, resulting in losing
of one's place when reading newsgroups.

Expected Results:  
Scroll amount per click should be constant, or at the least, a configurable option.

I'm setting this to "Minor" because it doesn't really impede the use of the
application; it's just an annoyance.
(Reporter)

Comment 1

14 years ago
Never mind, I found the problem.

MacOS X has a "Scrolling speed" slider in the mouse preferences. This controlls
the scroll wheel acceleration, and has nothing to do with Mozilla or Thunderbird.

Resolving invalid.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.