view-source on invalid protocol gives bogus error message

RESOLVED INVALID

Status

()

Toolkit
View Source
--
trivial
RESOLVED INVALID
15 years ago
2 years ago

People

(Reporter: Stevie-O, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.20 (Windows NT 5.0; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030

Going to an invalid protocol URL like this:

  bogus:foo

properly complains with a dialog box that 'bogus' is not a valid protocol.

However, going to

  view-source:bogus:foo

pops up a dialog saying that 'view-source' is not a valid protocol; after that, 
an empty view-source window is opened.


Reproducible: Always

Steps to Reproduce:
1. Type into your browser: view-source:bogus:foo
2. After seeing the (incorrect) error message, click OK to get a blank 
view-source window.

Actual Results:  
'view-source is not a registered protocol' followed by a blank View Source 
window.

Expected Results:  
'bogus is not a registered protocol', preferably *not* followed by a blank 
window :)
Typing this in the URL bar happens to work, but is not supported and is subject
to not working at any time... Fixing bugs in error reporting in functionality
that is essentially an easter egg is pretty low priority... ;)
Seeing this in Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208

Comment 3

15 years ago
Created attachment 144374 [details] [diff] [review]
Hack^WPatch to fix the described error.

This patch is based on the 'wyciwyg' logic in nsDocShell::InternalLoad.

It fixes two issues:
(1) "view-source is not a registered protocol"
(2) "could not be loaded" (a borked version of the 'www.foo.com could not be
loaded' error message )

Comment 4

15 years ago
That's not the only case. This URL also produces a bogus error message.
(As distinct from a bogus: error message, of course ;-)
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Comment 7

13 years ago
Still valid. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051121 Firefox/1.5 ID:2005112104
Status: RESOLVED → UNCONFIRMED
OS: Windows 2000 → All
Resolution: EXPIRED → ---

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

8 years ago
SeaMonkey trunk is now using toolkit viewsource.
Component: View Source → View Source
Product: SeaMonkey → Toolkit
QA Contact: view.source
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.