Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Todd Fabacher, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

In the page at http://www.iht.com/articles/117509.html, when you scroll down
FireBird draws the screen wrong. But ONLY when you scroll down.

Reproducible: Always

Steps to Reproduce:
1.goto http://www.iht.com/articles/117509.html
2.Scroll Down
3.

Actual Results:  
The browser does not draw the screen correctly.

Comment 1

14 years ago
Do you mean Firebird will scroll the text, while IE does not?

Comment 2

14 years ago
Todd, I cannot see any problem with Mozilla 1.6 on Win2000.
This is probably not a firebird bug, because the displaying engine is the same.
Todd, please describe the problem more clearly or attach a screenshot.
Component: History → General

Comment 3

14 years ago
(Fen Wu, 02/24/04) Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Follow-Up Tests:  
1. Type http://www.iht.com/articles/117509.html on the Mozilla Firebird
2. Scroll down and notice there is a big blank area following the text at the
bottom.

Do the same replication steps with IE and find no problem.

Comment 4

14 years ago
Todd, Fen:
> 2. Scroll down and notice there is a big blank area following the text at the
> bottom.

With Firefox 0.8 I see no such problem. Both of you are/were using 0.7, so
*maybe* updating helps. Bug 113779 was similar (and not easily reproducable),
but claimed to be fixed.

Comment 5

14 years ago
Created attachment 142387 [details]
...

repeatedly scrolling up and down, notice that the text appeared unproperly in
the mozilla firebird browser

Comment 6

14 years ago
Created attachment 142388 [details]
...

(Manan Pancholi & Oben Yapar) 26 February 2004

Successfully able to replicate the bug on Windows 2000 Professional with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

It is the same website, but it's working properly with Internet Explorer as
seen in the attachment file.

Comment 7

14 years ago
Oben Yapar:
> Successfully able to replicate the bug [...] with
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
> Firebird/0.7

Hello?
This was reproduced with Firebird 0.7 already, no use in doing this again.
As I already said: Firebird/now Firefox 0.8 is out quite a while now and I
cannot see anybody mentioning having seen this bug on this latest version.

Comment 8

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210
Firefox/0.8

"Scroll down and notice there is a big blank area following the text at the
bottom."  That blank area is caused by bad javascript code, thus is invalid.

There are actually two different bugs described in this thread.  One was about
the blank area, which is invalid, and the other was a drawing problem pointed
out by Oben Yapar, which is WFM.  Will mark as WFM since the original author
didn't specify which bug he was referring to, and Firefox/bird shouldn't have
drawn it as it did in Mr. Yapar's screenshot.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 9

14 years ago
A note about the bad Javascript code:

This is reproducable in both IE and Mozilla-based browsers.  Simply make the
window small, and then scroll down.  If it doesn't work, try making it smaller,
and try again.
You need to log in before you can comment on or make changes to this bug.