links to local anchors in HTML mails don't work anymore

RESOLVED DUPLICATE of bug 216154

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 216154
15 years ago
13 years ago

People

(Reporter: Tilman Schmidt, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.5) Gecko/20031007

Starting with Mozilla 1.5, links within HTML formatted mails referring to an
anchor within the same mail are shown on mouseover in the status bar with just a
slash in front, and when clicking them, the error message "is not a registered
protocol" (or localized equivalent) appears.

Reproducible: Always

Steps to Reproduce:
1. Receive HTML formatted mail containing local link to anchor.
   (Minimal example below.)
2. Point mouse to link.
3. Click on link.

Actual Results:  
In step 2, the link target is displayed in the status bar as: "/#1234".
In step 3, the error message: "is not a registered protocol." pops up.

Expected Results:  
In step 2, a link target within Mozilla's message store (starting with
"mailbox:") should appear.
In step 3, the cursor should jump to the referenced anchor (if it exists).

Minimal test mail exhibiting the problem:

Mime-Version: 1.0
Content-Type: text/html; charset=us-ascii

<html><body>
<p><A href="#1068200371">Test</A>
</body></html>

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 216154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.