If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

incorrect default location directory for cache files on Windows

VERIFIED DUPLICATE of bug 74085

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 74085
14 years ago
14 years ago

People

(Reporter: Benoît Rigaut, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Default Mozilla cache directory configuration on Windows is under C:\Documents
and Settings\brigaut\Application Data\Mozilla

Thus Microsoft is very precise about not using this "Application Data" directory
for temporary storage because of roaming profiles synchronisation:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/policy/policy/profiles_directory.asp

>>>>>Local Settings Application settings and data that do not roam with the
profile. Usually the settings or data in this directory are computer-specific,
or they are too large to roam effectively. This directory contains the following
subfolders: Application Data, History, Temp, Temporary Internet Files.

Reproducible: Always

Steps to Reproduce:
This configuration errors leads to impossible synchronisation when logging in ou
logging out on windows if the profile directory is on a server (too many file to
synchronise)
Actual Results:  
N/A

Expected Results:  
Use the "Local Settings" directory instead:

C:\Documents and Settings\brigaut\Local Settings\

Proposal for the default cache directory:

C:\Documents and Settings\brigaut\Local Settings\Application Data\Mozilla\Cache

thus the directory in default configuration should be

C:\Documents and Settings\brigaut\Local Settings\Application Data\Mozilla

... because oddly you have to point to an upper directory instead of the exact
cache directory containing cache files
Please search before you file a bug, this one is very easy to find.


*** This bug has been marked as a duplicate of 74085 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
V/dupe.
Status: RESOLVED → VERIFIED
QA Contact: cacheqa → benc
You need to log in before you can comment on or make changes to this bug.