email completion racing issue

RESOLVED DUPLICATE of bug 163103

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 163103
14 years ago
9 years ago

People

(Reporter: Benoît Rigaut, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When you use the email completion system, if you press the RETURN key and type
the begining of the next address, this leads to having the first letters of the
second email append at the end of the first email and the focus of the cursor on
the second line without any letters.

Reproducible: Sometimes

Steps to Reproduce:
1. type a name in the first email line of a new email windows
2. press the RETURN key *before* the completion has wrote the end of the email
3. just after the RETURN key, begin to type your second email address

Actual Results:  
The letters your typed after the RETURN key are at the end of the first email
address (after the @endofemail.com>). And the cursor has the focus on the second
line.

Expected Results:  
The letters typed after the RETURN key should be the first of the second line.

This occurs only if your computer is slow enough not to have time to have the
completion of the first line occurs before having the RETURN key down and the
other letters typed.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 163103 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.