Crashes on loading Web page

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: raych, Assigned: joshua.xia)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

I don't know whether I have the right component for this.

After this page loads for awhile, Moz crashes.

Reproducible: Always

Steps to Reproduce:
1. Access the page by any means.
2. Wail while it loads.
3. See Moz soon disappear.

Actual Results:  
See above.

Expected Results:  
Fully loaded the page properly.

There is JavaScript and an animated gif on this page.

The page loads properly into Netsc 4.8 and IE 6.0.2800.1106CO.

Just one of a million Web pages Moz gives up on, that the other browsers handle
just fine.

Comment 1

15 years ago
Reassigning to Browser-General until we can get a stack trace.

Raymond: if you can download a Talkback-enabled build, please
submit the Talkback form to us, then run the talkback.exe after
you crash to get the incident number, and post that number here. 

You can do this for more than one crash, if you wish. Once we get
the number(s), we can look up the stack trace(s) and figure out
where to assign this; thanks -
Assignee: live-connect → general
Component: Java: Live Connect → Browser-General
Keywords: crash, stackwanted
QA Contact: PhilSchwartau → general
Actually, I believe the talkback servers are not functional at the moment...

In any case, page loads with no crash with a Linux 2003-11-08-05 trunk build.

Comment 3

15 years ago
wfm 20031111 Win2k with Sun's JRE 1.4.2_02

Updated

15 years ago
Severity: major → critical

Comment 4

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031113
Java Plug-in 1.4.2_02 for Netscape Navigator (DLL Helper)

I´ve also tested your Bug 225196 Crashes when Java applet starts running

maybe you should upgrade to Java 1.4.2_02, I did it, after 1.4.1_01 was crashing
on another bug, and it cured my problem.

As you now got Java 1.4.2_01, can you please retest your 
Bug 220146 Browser crashes a few seconds after display of this URL

This one was working for me with Java 1.4.2_01, the one you used in bug 225196.

http://java.sun.com/products/plugin/
Severity: critical → major
(Reporter)

Comment 5

15 years ago
OK, I updated to Java 1.4.2_02.  Moz still crashes on the URL for this bug and
for the other two bugs discussed by Hermann.  (BTW, when I try to download any
of Java's JRE files, with either Moz or Netsc, an XLS extension becomes appended
to the file; and then, even if I remove this, the file won't install Java,
although its byte count is correct.  Again, IE can do this job fine.)  I just
can't see any light at the other end of the Mozilla tunnel of darkness.

The 1.5 version of Moz I have does have Talkback in it.  It has showed up at a
certain few times in the past when Moz crashes.  I don't see it now when it
crashes.  I don't see that your instructions for it don't seem to compute for me
and those in the Moz Help file are worthless.

Comment 6

15 years ago
It seems pretty clear this is an OJI problem; reassigning to OJI component -
Assignee: general → joshua.xia
Component: Browser-General → Java: OJI

Comment 7

15 years ago
Raymond, you have filed at least 7 crash bugs that occur when your Mozilla
enters a web site with Java.
Isn't it obvious that there is a problem with your java plugin that happens on
all(?) pages with java? 
So I strongly suggest you either resolve six of them as duplicates of one or
clearly state why the bugs have different causes in your opinion.
Thanks.
Severity: major → critical
(Reporter)

Comment 8

15 years ago
Andreas:

>Raymond, you have filed at least 7 crash bugs that occur when your Mozilla
>enters a web site with Java.

That is correct.  I see these seven under my name in the Bug List.

>Isn't it obvious that there is a problem with your java plugin that happens on
>all(?) pages with java?

No, only a few out of very many -- apparently those that include ticker displays
or certain other uncommon Java applications.  Furthermore, NONE of these 7 pages
fail to work properly with Netsc 4.8 or IE 6.0, let alone bring either of those
browsers down.  Netsc 4.x uses the same Java IRE code as Moz, right?  And
Netscape works on all these pages, while Moz works on none of them, but works on
many other pages.  'About Plugins' in Moz shows JRE 1.4.2_02 installed and
enabled.  I note that Sun now has JRE 1.4.2_03.  I'll downloads that soon and
see if these pages act any differently.  Unless Moz and Sun have banged heads
together on what it is in some uses of Java, in Win98SE (or with some particular
other program running in same), that Moz can't handle -- and this has resulted
in a corrective change in _03 -- I'm sure _03 will not correct the problems I
experience in these pages.  All of these pages, except that of Bug 225612,
include script for a ticker display.  225612 includes some kind of special
script to display genealogical trees.

>So I strongly suggest you either resolve six of them as duplicates of one or
>clearly state why the bugs have different causes in your opinion.

I'd say at least all but 225612 should be consolidated into one report.  Maybe
225612 should be in the same report also.  Durbacher should do whatever he wants
to with these 7.  This is not MY show.

In fact, checking all this out this evening took me a heck of a lot of time,
because 1) I'm not a software type or Web designer and 2) I have only a slow
Internet connection.  It's only YOU guys that would really know how you want to
consolidate various failures of your browser into common bug reports.  I can
only describe what I experience, either initially or upon a direction from you
experts; I don't have a mental map of the blocks of your code, that might
indicate which browser failures should be lumped within one bug report. 
Particularly, in the context of my observation that Moz people are actually
building just a browser for their special purposes, and don't care whether
general users can use their browser on a whole slew of Web pages -- but like to
brag that it will do certain exotic things that universal browsers can't exactly
duplicate (like present an opportunity for trying to read text as it is moved
over a background of seasnail shells) -- I should quit bothering to give them
data on what the general public can't do with their browser.  I originally
thought Moz wanted to know what people not in their clique had trouble doing
with their improved-in-numerous-ways, but forever-a-work-in-progress, browser.

This is the list of these 7 bugs that crash my installation of Moz 1.6b:

211642*
214016
216239
220146*
225196*
225612*  (no ticker, genealogical tree display instead)
216473   (URL changed to:  http://www.ripoffreport.com/default.asp  )

*The pages concerned with these bugs, for some reason, do not show their source
code in Netscape 4.8 but do in IE 6.0.

Ray

Comment 9

15 years ago
>>Isn't it obvious that there is a problem with your java plugin that happens on
>>all(?) pages with java?
> 
> No, only a few out of very many -- apparently those that include 
> ticker displays or certain other uncommon Java applications.  

Oh, ok. From your comments it always sounds like Mozilla is quite unusable for
you, so I got that wrong impression.

> 'About Plugins' in Moz shows JRE 1.4.2_02 installed and
> enabled.  I note that Sun now has JRE 1.4.2_03.

"Some time this year" they will offer 1.5.0. But it's difficult to predict if
either of them fixes the problem. I share your scepticism about that.

> All of these pages, except that of Bug 225612,
> include script for a ticker display.

Hmmm... this _could_ help narrow down the problem, but I doubt it. Why should
printing a text line to a different location all the time be such a lot more of
a problem than doing all the other nifty thing Java applets can do? Well...

>>So I strongly suggest you either resolve six of them as duplicates of one or
>>clearly state why the bugs have different causes in your opinion.
> 
> I'd say at least all but 225612 should be consolidated into one report.  Maybe
> 225612 should be in the same report also.  Durbacher should do whatever he 
> wants to with these 7.  This is not MY show.

Well, my remote diagnosis of course cannot detect if these bugs are really
caused by the same problem. However, I think you mentioned other URLs that also
fail and it obviously does not make sense to file a bug report for every one of
them.

Maybe I'll have a look at the bug reports to see if some of them eventually
could be duped to other ones. They all look just the same from the outside, so
it's a bit difficult to decide...

> In fact, checking all this out this evening took me a heck of a lot of time

I can imagine that, I am thankful and I sort of show my thankfulness by using
lots of _my_ spare time to analyze your problems.
I do not _have_ to do that, I could watch TV or go out, but I don't.

Unfortunately you don't seem to respect this - at least I do not see why else
you should keep insulting me and all those who are improving Mozilla in their
spare time.

Comment 10

15 years ago
By the way, I have read a comment by a Win98 user who solved his Java problems
by reinstalling an older version (1.4.0). However, one cannot know if his
problem was solved by reinstalling (your's obviously aren't) or by the older
version (I'm not sure if you already crashed with that one).

A thing to put some hope in is the revival of the Talkback crash reporting tool
mentioned above. Maybe already 1.6 final will have it and while some Java
crashes I read of do not trigger Talkback, others do. And that makes diagnosis
MUCH easier because developers can see what exactly failed.
(Reporter)

Comment 11

15 years ago
Please see my Comment #14 of Bug 220757.

Ray

Comment 12

15 years ago
This WFM, Mozilla 1.7b, JRE 1.4.1_07.
This is one of a series of bug reports that is reproducible only with this reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.