cannot display bitmap and exhaust cpu

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Sun Ke, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

i have tired to use another bitmap instead it , but it's currect. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Seem, that the server delivers the .bmp as plain text, so mozilla renders plain
text, instead of a bmp.

my window shows BM6¨!
(Reporter)

Comment 2

15 years ago
if i use ie6 view it , it;s okay ,so i don't think that server delivers 
the .bmp as plain text. and i assumen server delivers text string , can u tell 
me why my cpu exhaust out?

Comment 3

15 years ago
Unfortunately, the server actually is sending the bitmap as "text/plain" rather
than image/bmp or something else appropriate. Here is the actual header sent by
the server, note the Content-type field:

HTTP/1.1 200 OK
Date: Fri, 14 Nov 2003 13:59:18 GMT
Server: Apache-AdvancedExtranetServer/2.0.47 (Mandrake Linux/1.6.91mdk)
mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.47 OpenSSL/0.9.7a PHP/4.3.1
mod_fastcgi/2.4.0
Last-Modified: Wed, 21 Nov 2001 03:56:46 GMT
Etag: "ef89e-21a836-f876fb80"
Accept-Ranges: bytes
Content-Length: 2205750
Content-Type: text/plain

This probably works in IE because they tend to ignore Content-type and look at
the file extension to see what kind it is, which is something virus writers
enjoy exploiting.

As for the high CPU usage, I would guess that it simply takes a lot of work to
display such a large file although perhaps there is another bug on the issue
already (I'll look around).

Comment 4

15 years ago
I notice mozilla using 90+% of my CPU on LInux 2003112309.

Comment 5

14 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216

the image is diplayed and the cpu usage stays under 10%

Comment 6

14 years ago
This problem seems to have been resolved. If you find it is still an issue in
recent Mozilla builds, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.