Guided bug creation page does not list the same operating systems as the bug once it's created

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Wild Willy Kredentser, Assigned: myk)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.6a) Gecko/20031103
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.6a) Gecko/20031103

This is copied from Bug 12309:

> ------- Additional Comments From gerv@mozilla.org  2003-11-13 16:22 
> wildwilly@fuse.net: if you are on OS/2, the guided list should contain 
> OS/2. If it does not, file a bug.
> 
> Gerv

OK.  I'm filing.  I always do what I'm told.  <:-))

Actually, it's not just OS/2, but that's my favorite one .

Reproducible: Always

Steps to Reproduce:
1. Launch the guided bug creation process.
2. Inspect the operating system scrollable list.
3. After your bug gets created, look at the scrollable list inside the bug.
Actual Results:  
The scrollable list in the guided process is pretty short, but the list inside
the bug is pretty comprehensive.

Expected Results:  
The list inside the bug is the one that should also appear during the guided
creation process.
(Reporter)

Updated

14 years ago
OS: other → All
> Expected Results:  
> The list inside the bug is the one that should also appear during the guided
> creation process.

These are not the expected results. The list it shorter by design. It should
contain a few flavours of Windows, Linux, Mac OS, and whatever OS you are
currently running under, if it's not in that list. This is to make bug reporting
less confusing for newbies. 

Do you not see OS/2 in the list when running under OS/2? What exactly do you see?

Gerv
(Reporter)

Comment 2

14 years ago
Oh.  Alrighty then!  Then I amend my Expected Results.  OS/2 needs to be in the
list on the Guided Creation page.  It is missing now.
Right - so what exactly do you see, and in what order?

Gerv
(Reporter)

Comment 4

14 years ago
Oops.  Sorry about that.  Here's what I see:

other
Windows 98
Windows NT
Windows 2000
Windows XP
Mac System 9.x
MacOS X
Linux
All
This works on my local copy, but not on b.m.o. - I assume that the enhancement
which includes the OS you are running was checked in after b.m.o. last updated
itself.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.