Closed Bug 225698 Opened 19 years ago Closed 19 years ago

Tools Options Privacy settings not saved with installer version

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firebird0.8

People

(Reporter: guenter-huerkamp, Assigned: bugs)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031114 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031114 Firebird/0.7+

If i configure the cookies properties with the installer version of the nightly
builds, after I click the OK button FB has forgotten my preferences. I don't
have this problem with the .zip build. 

Reproducible: Always

Steps to Reproduce:
1.installer version
2.tools-option, preference cookies, ok, close
3.

Actual Results:  
.

Expected Results:  
.

.
*** Bug 225804 has been marked as a duplicate of this bug. ***
Confirming, 20031114 PC/WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true
Resummarizing as this bug appears to affect any option in Tools/Options/Privacy,
not just cookie settings.
Flags: blocking0.8?
Summary: configure cookies are not saved with the installer version → Tools Options Privacy settings not saved with installer version
*** Bug 225790 has been marked as a duplicate of this bug. ***
Possible (but painful) workaround : "about:config" .
As suggested by Jesse Ruderman, it didn't work right from the beginning, i.e.
2003-11-07-02-trunk/FirebirdSetup.exe .
(For such a bug, I'd suggest a "major" severity.)
Severity: normal → major
Another installer only regression that we should fix for 0.8. Setting TM.
Target Milestone: --- → Firebird0.8
I believe there are files missing from the installer package - which might be
causing this.  I unzipped the zip version ontop of my install and everything
started working properly again - but I didn't overwrite any files, I only added
files that were in the zip but not installed by the installer.

Might be worth looking into what files the installer might be missing....

-[Unknown]
If you set the preference "javascript.options.showInConsole" to true, you get
javascript errors when you try to set privacy options.  I would think that
someone who knows more about the code could tell from theses error messages what
needs to be added to the install package to fix this issue.
Did the fix in bug 225398 fix this bug?
Well, that fix was checked in before the 11/30 nightly was built.  Still does
not work, so, I guess the answer is no.
Fixed. 
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
This is only partially fixed.  Cookies work, Passwords do not.  Se my bug 227276
for details.
please add components/passwordmgr.xpt to package-static file,
it fixed the empty passwords dialog
Pre-release cleanup
Flags: blocking0.8? → blocking0.8+
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.