Installer not including all files

VERIFIED FIXED

Status

()

Firefox
Installer
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: alanjstr, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I compared yesterday's installer to today's zip file.  Here are the files that
are in the zip, but didn't get installed.  It seems that this prevents TBE from
working properly.  That might be because I choose to install TBE to the app dir.
 But it works with the zip build, so I figure there's something missing.

Only in MozillaFirebird: AccessibleMarshal.dll
Only in MozillaFirebird/chrome: chromelist.txt
Only in MozillaFirebird/chrome: embed-sample.jar
Only in MozillaFirebird/chrome: en-mac.jar
Only in MozillaFirebird/chrome: en-unix.jar
Only in MozillaFirebird/chrome: icons
Only in MozillaFirebird/chrome: modern.jar
Only in MozillaFirebird/components: accessibility-msaa.xpt
Only in MozillaFirebird/components: accessibility.xpt
Only in MozillaFirebird/components: alerts.xpt
Only in MozillaFirebird/components: appshell.xpt
Only in MozillaFirebird/components: autocomplete.xpt
Only in MozillaFirebird/components: autoconfig.xpt
Only in MozillaFirebird/components: bookmarks.xpt
Only in MozillaFirebird/components: caps.xpt
Only in MozillaFirebird/components: chardet.xpt
Only in MozillaFirebird/components: chrome.xpt
Only in MozillaFirebird/components: commandhandler.xpt
Only in MozillaFirebird/components: composer.xpt
Only in MozillaFirebird/components: content_base.xpt
Only in MozillaFirebird/components: content_html.xpt
Only in MozillaFirebird/components: content_htmldoc.xpt
Only in MozillaFirebird/components: content_xmldoc.xpt
Only in MozillaFirebird/components: content_xslt.xpt
Only in MozillaFirebird/components: cookie.xpt
Only in MozillaFirebird/components: directory.xpt
Only in MozillaFirebird/components: docshell_base.xpt
Only in MozillaFirebird/components: dom.xpt
Only in MozillaFirebird/components: dom_base.xpt
Only in MozillaFirebird/components: dom_core.xpt
Only in MozillaFirebird/components: dom_css.xpt
Only in MozillaFirebird/components: dom_events.xpt
Only in MozillaFirebird/components: dom_html.xpt
Only in MozillaFirebird/components: dom_range.xpt
Only in MozillaFirebird/components: dom_stylesheets.xpt
Only in MozillaFirebird/components: dom_traversal.xpt
Only in MozillaFirebird/components: dom_views.xpt
Only in MozillaFirebird/components: dom_xbl.xpt
Only in MozillaFirebird/components: dom_xpath.xpt
Only in MozillaFirebird/components: dom_xul.xpt
Only in MozillaFirebird/components: downloads.xpt
Only in MozillaFirebird/components: editor.xpt
Only in MozillaFirebird/components: embed_base.xpt
Only in MozillaFirebird/components: exthandler.xpt
Only in MozillaFirebird/components: find.xpt
Only in MozillaFirebird/components: gfx.xpt
Only in MozillaFirebird/components: helperAppDlg.xpt
Only in MozillaFirebird/components: history.xpt
Only in MozillaFirebird/components: htmlparser.xpt
Only in MozillaFirebird/components: imgicon.xpt
Only in MozillaFirebird/components: imglib2.xpt
Only in MozillaFirebird/components: intl.xpt
Only in MozillaFirebird/components: intlcmpt.xpt
Only in MozillaFirebird/components: jar.xpt
Only in MozillaFirebird/components: jsconsole.xpt
Only in MozillaFirebird/components: jsdservice.xpt
Only in MozillaFirebird/components: jsurl.xpt
Only in MozillaFirebird/components: layout_base.xpt
Only in MozillaFirebird/components: layout_xul.xpt
Only in MozillaFirebird/components: layout_xul_tree.xpt
Only in MozillaFirebird/components: locale.xpt
Only in MozillaFirebird/components: lwbrk.xpt
Only in MozillaFirebird/components: mimetype.xpt
Only in MozillaFirebird/components: mozbrwsr.xpt
Only in MozillaFirebird/components: mozfind.xpt
Only in MozillaFirebird/components: necko.xpt
Only in MozillaFirebird/components: necko_about.xpt
Only in MozillaFirebird/components: necko_cache.xpt
Only in MozillaFirebird/components: necko_cookie.xpt
Only in MozillaFirebird/components: necko_data.xpt
Only in MozillaFirebird/components: necko_dns.xpt
Only in MozillaFirebird/components: necko_file.xpt
Only in MozillaFirebird/components: necko_ftp.xpt
Only in MozillaFirebird/components: necko_http.xpt
Only in MozillaFirebird/components: necko_jar.xpt
Only in MozillaFirebird/components: necko_res.xpt
Only in MozillaFirebird/components: necko_strconv.xpt
Only in MozillaFirebird/components: necko_viewsource.xpt
Only in MozillaFirebird/components: nsInterfaceInfoToIDL.js
Only in MozillaFirebird/components: nsResetPref.js
Only in MozillaFirebird/components: nsSetDefaultBrowser.js
Only in MozillaFirebird/components: nsSetDefaultMail.js
Only in MozillaFirebird/components: nsUnsetDefaultMail.js
Only in MozillaFirebird/components: nsUpdateNotifier.js
Only in MozillaFirebird/components: oji.xpt
Only in MozillaFirebird/components: p3p.xpt
Only in MozillaFirebird/components: passwordmgr.xpt
Only in MozillaFirebird/components: pipboot.xpt
Only in MozillaFirebird/components: pipnss.xpt
Only in MozillaFirebird/components: pippki.xpt
Only in MozillaFirebird/components: plugin.xpt
Only in MozillaFirebird/components: pref.xpt
Only in MozillaFirebird/components: prefetch.xpt
Only in MozillaFirebird/components: prefmigr.xpt
Only in MozillaFirebird/components: profile.xpt
Only in MozillaFirebird/components: progressDlg.xpt
Only in MozillaFirebird/components: proxyObject.xpt
Only in MozillaFirebird/components: rdf.xpt
Only in MozillaFirebird/components: related.xpt
Only in MozillaFirebird/components: satchel.xpt
Only in MozillaFirebird/components: search.xpt
Only in MozillaFirebird/components: shistory.xpt
Only in MozillaFirebird/components: sidebar.xpt
Only in MozillaFirebird/components: txmgr.xpt
Only in MozillaFirebird/components: txtsvc.xpt
Only in MozillaFirebird/components: typeaheadfind.xpt
Only in MozillaFirebird/components: ucnative.xpt
Only in MozillaFirebird/components: uconv.xpt
Only in MozillaFirebird/components: unicharutil.xpt
Only in MozillaFirebird/components: uriloader.xpt
Only in MozillaFirebird/components: urlwidgt.xpt
Only in MozillaFirebird/components: util.xpt
Only in MozillaFirebird/components: webBrowser_core.xpt
Only in MozillaFirebird/components: webbrowserpersist.xpt
Only in MozillaFirebird/components: webshell_idls.xpt
Only in MozillaFirebird/components: websrvcs.xpt
Only in MozillaFirebird/components: widget.xpt
Only in MozillaFirebird/components: windowds.xpt
Only in MozillaFirebird/components: windowwatcher.xpt
Only in MozillaFirebird/components: winhooks.xpt
Only in MozillaFirebird/components: xml-rpc.xpt
Only in MozillaFirebird/components: xmlextras.xpt
Only in MozillaFirebird/components: xpcom_base.xpt
Only in MozillaFirebird/components: xpcom_components.xpt
Only in MozillaFirebird/components: xpcom_ds.xpt
Only in MozillaFirebird/components: xpcom_io.xpt
Only in MozillaFirebird/components: xpcom_obsolete.xpt
Only in MozillaFirebird/components: xpcom_thread.xpt
Only in MozillaFirebird/components: xpcom_xpti.xpt
Only in MozillaFirebird/components: xpconnect.xpt
Only in MozillaFirebird/components: xpinstall.xpt
Only in MozillaFirebird/components: xremoteservice.xpt
Only in MozillaFirebird/components: xuldoc.xpt
Only in MozillaFirebird/components: xultmpl.xpt
Only in MozillaFirebird/defaults/pref: editor.js
Only in MozillaFirebird/defaults/pref: mailnews.js
Only in MozillaFirebird/defaults/profile: chrome
Only in MozillaFirebird/defaults/profile: panels.rdf
Only in MozillaFirebird: mozctl.dll
Only in MozillaFirebird: mozctlx.dll
Only in MozillaFirebird: regchrome.exe
Only in MozillaFirebird: regxpcom.exe
Only in MozillaFirebird/res: arrowd.gif
Only in MozillaFirebird/res: bloatcycle.html
Only in MozillaFirebird/res: grabber.gif
Only in MozillaFirebird/res: html
Only in MozillaFirebird/res: rdf
Only in MozillaFirebird/res: table-add-column-after-active.gif
Only in MozillaFirebird/res: table-add-column-after-hover.gif
Only in MozillaFirebird/res: table-add-column-after.gif
Only in MozillaFirebird/res: table-add-column-before-active.gif
Only in MozillaFirebird/res: table-add-column-before-hover.gif
Only in MozillaFirebird/res: table-add-column-before.gif
Only in MozillaFirebird/res: table-add-row-after-active.gif
Only in MozillaFirebird/res: table-add-row-after-hover.gif
Only in MozillaFirebird/res: table-add-row-after.gif
Only in MozillaFirebird/res: table-add-row-before-active.gif
Only in MozillaFirebird/res: table-add-row-before-hover.gif
Only in MozillaFirebird/res: table-add-row-before.gif
Only in MozillaFirebird/res: table-remove-column-active.gif
Only in MozillaFirebird/res: table-remove-column-hover.gif
Only in MozillaFirebird/res: table-remove-column.gif
Only in MozillaFirebird/res: table-remove-row-active.gif
Only in MozillaFirebird/res: table-remove-row-hover.gif
Only in MozillaFirebird/res: table-remove-row.gif
Only in MozillaFirebird/res: viewer.properties
Only in MozillaFirebird: shlibsign.exe

Comment 1

14 years ago
I can confirm this for Gecko/20031116 Firebird/0.7+

A separate bug, #225398, is filed about missing files in res/html directory.

Another side effect of missing files is that the "Edit->Find In This Place"
dialog box does not function.  This is a rather severe degradation of
performance, and severity should be raised to Major.
(Reporter)

Comment 2

14 years ago
I believe the broken Find is due to something else.  pch said it was going to
get a rewrite.

What does the res stuff do?

mailnews.js and editor.js are being removed from the zip file via two other bugs
I filed, so you can ignore them.  modern.jar is a different bug as well.

Comment 3

14 years ago
>Only in MozillaFirebird: AccessibleMarshal.dll
>Only in MozillaFirebird/components: accessibility-msaa.xpt
>Only in MozillaFirebird/components: accessibility.xpt

The installer builds seem to be compiled with the disable-accessibility flag

>Only in MozillaFirebird: shlibsign.exe
>Only in MozillaFirebird: regchrome.exe
>Only in MozillaFirebird: regxpcom.exe

Firebird never needed these files. I've deleted them from my own builds for ages
and never had problems.

>Only in MozillaFirebird/chrome: chromelist.txt
>Only in MozillaFirebird/components: nsInterfaceInfoToIDL.js
>Only in MozillaFirebird/components: nsResetPref.js
>Only in MozillaFirebird/components: nsSetDefaultBrowser.js
>Only in MozillaFirebird/components: nsUpdateNotifier.js
>Only in MozillaFirebird: mozctl.dll
>Only in MozillaFirebird: mozctlx.dll
>Only in MozillaFirebird/res: arrowd.gif
>Only in MozillaFirebird/res: grabber.gif
>Only in MozillaFirebird/res: viewer.properties

Not sure about those.

>Only in MozillaFirebird/chrome: icons

This is needed, right.

>Only in MozillaFirebird/chrome: embed-sample.jar
>Only in MozillaFirebird/chrome: en-mac.jar
>Only in MozillaFirebird/chrome: en-unix.jar
>Only in MozillaFirebird/chrome: modern.jar

Those files are not needed, since the installer is windows-only, modern is not
packaged with firebird and the embed-sample is useless on an end-user application.

>all the other xpt-files:

Take a look at the size of the component folder in both versions. They are
basically the same. As far as I know the installer-version bundles all these
xpt-files to one big file.

>Only in MozillaFirebird/components: nsSetDefaultMail.js
>Only in MozillaFirebird/components: nsUnsetDefaultMail.js
>Only in MozillaFirebird/defaults/pref: editor.js
>Only in MozillaFirebird/defaults/pref: mailnews.js

This is a browser, so we don't need this stuff.

>Only in MozillaFirebird/res: html
>Only in MozillaFirebird/res: rdf

At least for one of those directories a bug exists.

>Only in MozillaFirebird/res: bloatcycle.html
>all the table-files

These files can be safely deleted. They aren't used.

So I will confirm this for developer review, but expect most of these files to
be gone for good.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

14 years ago
Why are we disabling Accessibility?  Once we figure out what can go, I'll file a
bugs for blocking bug 171082.

Adding Bryner since he's got 171082 and Blake because he reported 171082.
(Reporter)

Comment 5

14 years ago
res/html has been handled in 225398

Some xpt files were handled in Ben's checkin on 11/29, which may be relevant.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/installer/windows&command=DIFF_FRAMESET&file=packages-static&rev1=1.7&rev2=1.8&root=/cvsroot

A new diff should be performed.  Simon, this is probably going to wind up being
a meta-bug for tracking things that need to go into the installer and not those
that should be eliminated since that is meta-bug 171082.

We still need a dev to run through the list and pick out those that we know
should be included.  Basically, I'm looking for parity between the zip and the
installer.  If one has file Foo, then the other should also have Foo until Foo
is resolved.  
Depends on: 225398

Comment 6

14 years ago
*** Bug 227292 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 227276
(Reporter)

Comment 7

14 years ago
Wouldn't the cookie manager be a blocker of this bug and not a dupe?  Does
adding in cookies.xpt fix it?  

We still need to find someone who can tell us what .xpt files are and have them
run through that list.

Updated

14 years ago
Depends on: 227292

Comment 8

14 years ago
Yup, I've confirmed the cookie bug and I've added it to the blocker list of this
bug.
(Reporter)

Comment 9

14 years ago
http://lxr.mozilla.org/mozilla/source/browser/installer/windows/packages-static

I'm confused.  I see cookie.xpt on that list.  Ben just added 

The only two .xpt files in today's installer build are browser.xpt and
inspector.xpt, so where are the rest of them going?  
Well I am confused too.  I am running the Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.6b) Gecko/20031202 Firebird/0.7+ installer build and cookies
work just fine with this build, so I do not understand comment #8.
(Reporter)

Comment 11

14 years ago
William, please direct cookie comments to bug 227292
My reason for posting here is that people commented here, AFTER THE 12/02
NIGHTLY WAS AVAILABLE, verifying that the cookie bug which was fixed in the
12/02 nightly still exists.  My point was that people who are going to post
verifiction that things are failing with current builds should actually be
running the current build.
Here is a better list of missing .xpt files.  The following is a list of .xpt
files from the 12/02 windows zip that do NOT appear in
browser/installer/windows/packages-static.

alerts.xpt
composer.xpt
downloads.xpt
htmlparser.xpt
intlcmpt.xpt
jsconsole.xpt
lwbrk.xpt
mozfind.xpt
necko_file.xpt
necko_viewsource.xpt
p3p.xpt
passwordmgr.xpt
plugin.xpt
prefetch.xpt
ucnative.xpt
windowds.xpt
xremoteservice.xpt

Some of these (composer.xpt is a great example) would appear not to be needed
becuase Firebird does not use them.  This assumption is not valid because
extensions might use them.  The currently under developement spellchecker for
form fields requires composer.xpt.
(Reporter)

Comment 14

14 years ago
Does inspector.xpt extracted even if DOMI is not installed?  Probably not, since 
it is in a seperate section in the packages list.  

Spellchecker should be responsible for including it for when it is installed.

Does Midas require composer.xpt?  
IMHO ALL these files either need to be included in the installer version, or
removed from the zip version.  We can't have them both being different and
expect people to be able to develop extensions and themes, etc.  They should not
have to test everything twice, once on the zip and once on the installer
version.  The 2 versions should be identical.
(Reporter)

Comment 16

14 years ago
And thats what this bug is about; files are missing from the installer.  Files
that are deemed to not be needed should be marked as blocking bug 171082 which
is what I said in number 5.

Updated

14 years ago
Depends on: 227367
Simply put, an .xpt file is basically just information about a given interface.
Say an interface for "foo" is developed called nsIFoo, placed in nsIFoo.idl.
Processing that idl file in the build process generates headers and foo.xpt. A
component still needs to be present (either as a dll file or a js component)
that implements that interface. So some of these extra .xpt files offer nothing
to extension developers if the dll files containing the implementations of the
interfaces the .xpt files identify do not exist. 
Status: NEW → ASSIGNED
(Reporter)

Comment 18

14 years ago
To put it into language that I understand:  all the included .xpt files are
rolled into browser.xpt, so if they're not on the packager list, they're not in
there.  See Comment 13.
OK, I've adjusted the packager file a little. I don't think we need these files
on Windows right now:

Only in MozillaFirebird/components: autoconfig.xpt
Only in MozillaFirebird: AccessibleMarshal.dll
Only in MozillaFirebird/components: composer.xpt
Only in MozillaFirebird/components: nsInterfaceInfoToIDL.js
Only in MozillaFirebird/components: nsResetPref.js
Only in MozillaFirebird/components: nsSetDefaultBrowser.js
Only in MozillaFirebird/components: nsSetDefaultMail.js
Only in MozillaFirebird/components: nsUnsetDefaultMail.js
Only in MozillaFirebird/components: nsUpdateNotifier.js
Only in MozillaFirebird/components: p3p.xpt
Only in MozillaFirebird/components: urlwidgt.xpt
Only in MozillaFirebird/components: xremoteservice.xpt
I think this is now fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.