Closed Bug 22577 Opened 20 years ago Closed 20 years ago

[Dogfood]Crash going to Bugsplat URL after fresh Seamonkey launch

Categories

(Core :: Networking, defect, P1, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: scalkins, Assigned: harishd)

References

()

Details

(Whiteboard: [PDT+])

Saw this on Win build only  1999-12-23-09 M13

Steps to repro:
1)If you are in Seamonkey, exit Seamonkey.
2)Re-Launch Seamonkey, and after the home page loads,type the following URL in
Mozilla:
http://scopus/bugsplat
3)Hit the enter key after typing this.

Expected results: This takes you to the a page which reads "Error in
Authentication, try to relogin and then repeat the operation. Click Here to
login".

Actual results: You will crash.
Talkback trace below:
Incident ID 2896587
 Trigger Time
               1999-12-23 12:02:46
 Email Address
               scalkins@netscape.com
 User Comments
               Crash in Mozilla after a fresh launch when i types
http://scopus/bugsplat in the url and hit enter key.Win build 11999-12-23-09 M13
 Build ID
               1999122309
 Product ID
               Communicator5.0
 Platform ID
               Win32
 Stack Trace

nsCRT::strlen [d:\builds\seamonkey\mozilla\xpcom\ds\nsCRT.cpp, line 228]
nsString::Append [d:\builds\seamonkey\mozilla\xpcom\ds\nsString2.cpp, line 1167]
nsString::Assign [d:\builds\seamonkey\mozilla\xpcom\ds\nsString2.cpp, line 1025]
nsJSContext::EvaluateString
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 309]
HTMLContentSink::EvaluateScript
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 3845]
HTMLContentSink::ProcessSCRIPTTag
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 4036]
HTMLContentSink::AddLeaf
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp,
line 2819]
CNavDTD::AddLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3213]
CNavDTD::HandleScriptToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1870]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 2900]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1119]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1421]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 814]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 573]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1043]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 965]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1335]
nsDocumentBindInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1465]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 218]
nsChannelListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1613]
nsHTTPResponseListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 205]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
370]
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
94]
PL_HandleEvent [plevent.c, line 523]
_md_EventReceiverProc [plevent.c, line 955]
USER32.dll + 0x1820 (0x77e71820)
Priority: P3 → P1
Assignee: nobody → gagan
Component: Browser-General → Networking
QA Contact: nobody → tever
Summary: Crash going to Bugsplat URL after fresh Seamonkey launch → [Dogfood]Crash going to Bugsplat URL after fresh Seamonkey launch
tever, do you see this with today's build?
Assignee: gagan → harishd
Target Milestone: M14
Works for me in non-commercial build.

If anything, this looks like a parser bug, not necko.
This doesn't crash for me.  Everything loaded fine :)
Whiteboard: [PDT+]
tever, can you reproduce on a commercial build? Putting on PDT+ radar.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This is working for me.  Verified NT 2000011808.  Message from
Harish stated working for him also.
Status: RESOLVED → VERIFIED
"
You need to log in before you can comment on or make changes to this bug.