The default bug view has changed. See this FAQ.

Ability to pass URLs to helper apps (for streaming) instead of downloading and then passing the entire file

NEW
Unassigned

Status

()

Firefox
File Handling
14 years ago
6 years ago

People

(Reporter: Sander Van de Moortel, Unassigned)

Tracking

(Depends on: 1 bug)

unspecified
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Well, FireBird just won't do what IE did so well: start playing a movie as soon
as the first kilobytes have arrived. Firebird will attempt to download the whole
file first before opening/playing it.

Try any mpg/wmv/avi/... file

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
MPEG and AVI aren't even streamable file formats, so even IE won't stream them.
WMV is a streaming file format, and I've seen Firebird successfully pass a WMV
URL to Windows Media Player and stream it before. The problem with WMV is that
for this to work, the correct MIME type needs to be set on the server side.

Comment 2

14 years ago
I don't think that this is a bug at all, as Firebird in this case is basically
performing to W3C spec. Marking as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
What media player?  What URL?  
(Reporter)

Comment 4

14 years ago
not true. IE will open the vid as soon as the first kilobytes have arrived. EVEN
an AVI format, which is just an extension for any video format, so it seems.

MediaPlayer 9 by the by
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

14 years ago
You have still not provided URLs for us to confirm.
(Reporter)

Comment 6

14 years ago
http://www.easycut.com/Cut_Steel.avi
(Reporter)

Comment 7

14 years ago
ftp://ftp.talonsoft.com/pub/movies/dogsofwar/dogsofwar-clip1.mpg

Comment 8

13 years ago
It sounds like Firebird is downloading the file and then calling the
application, instead of telling the external application to download it.  
Assignee: blake → bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
The option could be to call the app directly, however this would be nontrivial
to implement, as we would need to identify whether the file can be played while
not fully downloaded, then instead of downloading and calling the app with the
local filename, calling the app with the remote filename and let the app handle that

not all apps are necessarily network-aware to this extent though
QA Contact: mconnor
Summary: No streaming video in firebird → Video files have to be fully downloaded before playing

Comment 10

13 years ago
This is closely related to bug 137339.

Comment 11

13 years ago
Updating summary. This is most certainly not a bug, as I mentioned in comment 2.
This is an enhancement request. Marking as such.

RE comment 1, I may have actually opened up a playlist, which is why it appeared
to stream the files in WMP. Had I clicked on a media file directly, it would
have downloaded and then played.

I do think that its quite possible that this is a dupe of bug 137339, but I'm
not sure because we have forked download code. Ben, can you comment?
Severity: normal → enhancement
Summary: Video files have to be fully downloaded before playing → Ability to pass URLs to helper apps (for streaming) instead of downloading and then passing the entire file
Whiteboard: Dupe of 137339?

Comment 12

13 years ago
Moving to new File Handling component.
Component: Download Manager → File Handling

Comment 13

13 years ago
*** Bug 249437 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
Per bsmedberg, bumping this up to normal sev and cc'ing biesi.
Severity: enhancement → normal

Comment 15

13 years ago
There's an extension now called "Download With" that may have code that would be
helpful to add this URL passing function to the firefox core.
yeah, this looks like the firefox version of bug 137339

probably depends on some backend work, marking dependency (frontend is forked,
so not marking as dup)
Depends on: 137339

Updated

13 years ago
Whiteboard: Dupe of 137339?
*** Bug 291884 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
Created attachment 181868 [details]
UI part of the streaming/direct open support

Of course that UI part is only the tip of the iceberg. The fix goes deeper into
the mimeTypes.rdf

Comment 19

12 years ago
One possible solution to store the configuration for helper applications is to
ammend the MimeTyped.rdf. The namespace NC
xmlns:NC="http://home.netscape.com/NC-rdf#" would need a new attribute.
My suggestion would be NC:openFromURL="true" in the decription. A complete
description would look like this:
<RDF:Description RDF:about="urn:mimetype:handler:application/x-zip"
                   NC:alwaysAsk="true"
                   NC:openFromURL="true"
                   NC:saveToDisk="true">
Then the code from the "Download with merged into the core" could do the rest.
It would not only be streaming that benefits from a direct url support. Also
office productivity software that uses webDAV would need that function making FF
more attractive for corporate use

Comment 20

12 years ago
*** Bug 311954 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Duplicate of this bug: 367485
Assignee: bugs → nobody
OS: Windows XP → All
QA Contact: mconnor → file.handling
Hardware: PC → All

Comment 22

9 years ago
I can very well reproduce here with Firefox 2, and my reporter of the Fedora Rawhide bug (https://bugzilla.redhat.com/show_bug.cgi?id=327681) reports to reproduce it with the latest FF3 build.

Steps to reproduce:
1. click on http://audio-ogg.ibiblio.org:8000/wcpe.ogg.m3u
2. select Rhythmbox as player for your stream

Actual result:
Rhythmbox thinks that this is reload of whole stream from the local file and so replaces all old radio stations with the new stream

Expected results:
Firefox is passing URL to Rhythmbox, which then handles it as it should
Flags: blocking-firefox3?

Comment 23

9 years ago
Sorry, this should go probably to https://bugzilla.mozilla.org/show_bug.cgi?id=137339
This will not block the final release of Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-
You need to log in before you can comment on or make changes to this bug.