menu font becomes smaller when screen resolution is increased

RESOLVED DUPLICATE of bug 197037

Status

Core Graveyard
GFX: Gtk
RESOLVED DUPLICATE of bug 197037
15 years ago
5 years ago

People

(Reporter: Simon Anders, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031103
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031103

When selecting 96 dpi in Preferences|Appearence|Fonts|Display Resolution, the
menu font is _smaller_ than at 72 dpi. Shouldn't it rather be _larger_ in order
to compensate for the smaller size of an individual pixel?

I'm using Mozilla 1.6a with XFT on a 1280x1024 screen.

Reproducible: Always

Steps to Reproduce:
1. Select 72 dpi in said drop-down box, press Ok, and restart Mozilla.
2. Remember the size of the menu font.
3. Select 96 dpi and restart again.
4. Behold how the menu font is now smaller instead of larger.
(Reporter)

Comment 1

15 years ago
The same bug also appears when using the ruler that one gets when clicking on
"Other" in the screen resolution drop-down box: If one claims the ruler to be
very long on ones screen, Mozilla correctly deduces a small screen resolution
(small dpi value) but then uses (after restart) a huge font instead of an
especially small one.

Hence I might have filed this bug in the wrong category: The preferences dialog
does its job fine, i.e. it stores the right dpi value. The fault seems to be in
the module that chooses the menu font. Probably the font size it gotten there by
dividing some constant by the dpi value instead of multiplying with it.

Could somebody who knows how to do it please move this bug to the proper category?
> I'm using Mozilla 1.6a with XFT

The XFT code actually uses a hardcoded DPI value to convert from
mozilla-internal representation to screen; what you're seeing is that the
mozilla-internal representation is adjusted correctly and XFT screws up.

With my non-xft build, a smaller dpi setting leads to a smaller font.

To blizzard, but I think we have a bug on this already...
Assignee: prefs → blizzard
Component: Preferences → GFX: Gtk
QA Contact: ian
Whiteboard: DUPEME

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 197037 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.