<FORM> tag doesn't work in optimized build.

NEW
Unassigned

Status

()

P3
normal
19 years ago
12 years ago

People

(Reporter: yixiong.zou, Unassigned)

Tracking

Trunk
Future
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
if we build viewer using the following switchs on linux:
CFLAGS=-O2 CXXFLAGS=-O2 ./configure --with-pthreads --disable-mailnews --enable-
editor --disable-gtk-mozilla --disable-debug
Run "viewer res:///res/samples/test_form.html", click on the text box, viewer
will crash.

Comment 1

19 years ago
Created attachment 3960 [details]
sample file

Updated

19 years ago
Assignee: beppe → kin
Severity: blocker → normal

Updated

19 years ago
Target Milestone: M15

Comment 2

19 years ago
the breakage must have something to do with the switch settings, if I just
launch the optimized build and display a form sample page (see attached) the app
works just fine. Downgrading to normal and setting to m15

Kin -- can you reproduce this one?

Comment 3

19 years ago
forgot to set milestone

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
Accepting bug.

yixiong.zou@intel.com, do you have a stack trace you can add to the bug?
(Reporter)

Comment 5

19 years ago
Not yet. The bug only appears with optimized build + switches.
(Reporter)

Comment 6

19 years ago
I tested it again. The bug only appears if we build mozilla in release mode,
where we specify CFLAGS etc. Also, if you test the browser using
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=3960, the test page
won't even load. The browser just crashes.

Comment 7

19 years ago
Moving all non-beta1 bugs to M16 since I am going on sabbatical.
Target Milestone: M15 → M16

Comment 8

19 years ago
moving to m18
Target Milestone: M16 → M18

Comment 9

19 years ago
marking as later
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 10

19 years ago
reopening and marking Future...
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Target Milestone: M18 → Future

Comment 11

19 years ago
Accepting bug.
Status: REOPENED → ASSIGNED
QA Contact: sujay → editor
Assignee: kinmoz → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.