Quoted Message taken from selected msg in directory window rather than original message

RESOLVED DUPLICATE of bug 181028

Status

MailNews Core
Composition
--
minor
RESOLVED DUPLICATE of bug 181028
14 years ago
9 years ago

People

(Reporter: Robert DiGrazia, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031117
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031117

When quoting in a reply to messages opened in the Search window,
the message selected in the directory window is quoted (see bug 187852).

Reproducible: Always

Steps to Reproduce:
1. Select a message in the directory window (the "front end"?  ... where the
messages are listed)
2. Search for messages.
3. Open a message from the search window.  (Double click to get a new window.)
4. Reply to the opened message.
5. Quote.  
Actual Results:  
The text of the message selected in the directory window is quoted.

Expected Results:  
Quoted the text of the message to which I am replying.

I see this in 1.5 and 1.6b.
I came across bug 187852, from Jan 2003 (I think).
(Oddly, I couldn't find 187852 by searching for "mail quote" etc.)
I consider this Major: imagine what might be quoted to the wrong addressee!

Comment 1

14 years ago
You don't need to go thru the Search interface; this symptom can be easily 
replicated by:
  Select a message in the thread pane
  Reply
  Select another message in the thread pane
  In the compose window, select Quote Message:
The currently-selected message is quoted.

Same thing if you simply open a compose window with New Message -- in this case, 
would you see Quote Message disabled, since there is no "original" message?

This may actually be by design, I don't know.  I can make the case that some 
people might want to quote multiple messages within a single reply; this 
behavior makes that possible.

At any rate, it is not major: there is no loss of function.  In fact, there is a 
simple workaround: Make sure the message you intend to quote is the one 
selected, and be sure to read your mail before sending.  Therefore, reducing 
severity to Minor.
  http://bugzilla.mozilla.org/bug_status.html#severity
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Search for msg, reply: quote taken from selected msg in directory window → Quote Message taken from selected msg in directory window rather than original message
(Reporter)

Comment 2

14 years ago
Thanks for your thoughtful comments.
However, I expect to quote the message to which
"reply" applies, not a message selected in some long-forgotten window.
From the viewpoint of a user, quoting the "wrong" message can
have unpleasant consequences.  (Your attorney can amplify.)

Regards, Bob
Summary: Quote Message taken from selected msg in directory window rather than original message → Quoted Message taken from selected msg in directory window rather than original message

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 181028 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.