firebird crashes after clicking the link to download windows nightly build of either firebird or mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Carol Bean, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031116 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031116 Firebird/0.7+

I haven't been able to test this on mozilla since I can't download mozilla. 
This past weekend there was a file not found error when I clicked the link for
the mozilla nightly build.  Today, clicking the link crashes Firebird.  I tried
it with the link for the firebird nightly build and got the same result.

Reproducible: Always

Steps to Reproduce:
1.Open Firebird
2.Go to http://www.mozilla.org/developer/
3.Click on link for nightly build for windows version of either firebird or mozilla.

Actual Results:  
Firebird crashes

Expected Results:  
downloaded the file.

the error just says illegal operation.

Comment 1

15 years ago
Hi Carol, the download works fine for me. I'm using Win XP version 20031116
Firebird/0.7+ as well. So, maybe it's a Win98-specific problem...

One thing: if you look in Tools->Options->Downloads where is it configured to
save files to? Is it possible it's been set to somewhere that doesn't exist?

If that's not the issue, before someone tries to debug this for you, could you
please try running Firebird with a fresh profile: either trash your old
profile(temporarily at least), or start the profile manager (see:
http://texturizer.net/firebird/faq.html#profilemanager).

If that works, please let us know :)
(Reporter)

Comment 2

15 years ago
Downloads are set to go to desktop.
I removed Firebird and deleted the profile.  Reinstalled Firebird and created a
new profile.  Still crashes trying to download the nightly build.

Comment 3

15 years ago
What if you set the downloads preference to ask you where to save the file each
time?
(Reporter)

Comment 4

15 years ago
Nope, still crashes with options set to ask where at each download.  Never even
gets to the dialog box.  But on the last crash, it did give these details:
MOZILLAFIREBIRD caused an invalid page fault in
module XPCOM.DLL at 017f:1000168c.
Registers:
EAX=00000000 CS=017f EIP=1000168c EFLGS=00010246
EBX=00000000 SS=0187 ESP=00e4f2e0 EBP=00e4f2f8
ECX=00000000 DS=0187 ESI=00e4f314 FS=2f47
EDX=00000000 ES=0187 EDI=00000000 GS=0000
Bytes at CS:EIP:
66 8b 11 41 41 66 85 d2 75 f5 c3 8b 44 24 04 8b 
Stack dump:
1003ea4d 00000000 1003f1b6 00000000 00000000 80000000 00e4f374 0071735d 00000000
ffffffff 00e4f6d8 1003f1b6 00000000 10044960 00e4f324 00000000 

Comment 5

15 years ago
Oh :( Sorry, I can't help you with that. I'm just a user that tries to help out
with basic debugging, and not much use with system error messages. I hope
someone more tech savvy can come up with an answer for you.

Before I go quiet, however, there's a few more things to consider:

- Do you have any Firebird extensions installed, or extra themes, or extra
plugins? If so, what happens if you remove them?

- One thing I don't think you mentioned... does the download link work with
Internet Explorer?

- Also, have you tested it on other downloads (from other sites) that have http
transfers of .exe files?

- One final thought, what happens if you disable any anti-virus software?
(Reporter)

Comment 6

15 years ago
First, I haven't installed any extensions or themes in Firebird, and no plugins
other than what is being used by all browsers.
Second, the download works with I.E. (which is how I was able to get a new copy
and re-install :-)
BTW, since I was able to download Mozilla with I.E., I tried the download with
Mozilla:  it crashes also.
I haven't tried any other downloads since it started crashing, but it was
working fine before I downloaded the current nightly build I'm using.
Finally, the antivirus auto-protect is disabled by default.  That may have
something to do with it, since I can't seem to get it to launch at boot with
auto-protect any more.  But I have tried the download both with and without
auto-protect turned on.

Comment 7

15 years ago
Well, I'm afraid I'm stumped (short of suggesting you remove your antivirus
software entirely and reinstall it, since it sounds like it's misbehaving
anyway). :( I don't have access to a Win 98 machine to test out, either. As I
said, I hope someone else can pinpoint the problem. Sorry I couldn't be more
help. cheers.

Comment 8

15 years ago
Hi Carol,

thanks for checking with mozilla too, since the problem is in both mozilla and
firebird this bug should be moved over to the browser component (doing that now).

Something else to try - can you download any other binary files (e.g.
executables)? either from mozilla.org or another site. Does ftp work for you?

bob
Assignee: blake → download-manager
Severity: major → critical
Component: Downloading → Download Manager
Product: Firebird → Browser
Version: unspecified → Trunk
(Reporter)

Comment 9

15 years ago
Haven't done ftp, but I was able to download various .exe files from pcworld
just now without any problems.

Comment 10

14 years ago
Note to self: since the problem occurs with clean profile this probably is not a
dupe of bug 235537

Comment 11

14 years ago
Marking WFM :

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040321
Firefox/0.8.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.