Open Link in New Window/Tab on Windows UNC path link don't open window/tab

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 84128
14 years ago
13 years ago

People

(Reporter: Daniel B., Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

Given an HTML mail message containing a link with a file-scheme URL containing
a Windows-style UNC pathname, the Open Link in New Window and Open Link in New
Tab context-menu commands do not open the link (no window or tab is created,
and neither does any existing tab or window even get raised).

This happens even for a valid URL (one that works when pasted into a Navigator
window address box).

The URL was of the form "file:///\\Fileserver\dir\...\file.ext".

(The literal (quoted-printable-encoded) message source was:
...
<a
href=3D"file:///\\Fileserver3\documents\administration\personnel\performa=
nce_management\performance_plan.dot">\\Fileserver3\documents\administrati=
on\personnel\performance_management\performance_plan.dot</a>
...

The literal URL was:

 
file:///\\Fileserver3\documents\administration\personnel\performance_management\performance_plan.dot

)


Reproducible: Always

Steps to Reproduce:
1.  Right click on the link in the mail message.
2.  In the context menu, select the Open Link in New Window or the Open Link in
    New Tab command.
3.  Notice that nothing happens.

Actual Results:  
Nothing.  

Expected Results:  
Opening a new window or tab.  (Even if the link's URL was invalid, Mozilla
should have opened a new window or tab and left the original URL in the 
address bar, e.g., for further editing by the user.)
Check the JS console -- is there a security exception thrown?  If so, dup of bug
84128
yes, that's a dupe of bug 84128

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.