whitespace chars appended to email address prevents successful login

RESOLVED DUPLICATE of bug 161369

Status

()

--
minor
RESOLVED DUPLICATE of bug 161369
15 years ago
6 years ago

People

(Reporter: keithrhaynes, Assigned: myk)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Bugzilla Version 2.16.3 

The login page should trim white space characters from the "E-mail address:" 
field before login validation occurs.

Reproducible: Always

Steps to Reproduce:
1. Go to the login page
http://bugs.theinsiders.com/query.cgi?GoAheadAndLogIn=1
2. Paste in your normal, valid email address (say user@company.com)
3. Append a space char to the end of your email address (say user@company.com )
4. Input you normal, valid password
5. Click the "Login" button
Actual Results:  
Error text is displayed, like:
The e-mail address you entered(user@company.com ) didn't pass our syntax 
checking for a legal email address. A legal address must contain exactly 
one '@', and at least one '.' after the @. It must also not contain any of 
these special characters: \ ( ) & < > , ; : " [ ], or any whitespace. 


Expected Results:  
Bugzilla to perform a trim on the email address field before validation.
(Reporter)

Comment 1

15 years ago
Alterntatively, the html in the standard footer could be altered to not insert 
a whitespace character after the email address of the current user:

See this page:
http://bugs.theinsiders.com/query.cgi

And note this section of text:
Edit prefs | Log out khaynes@theinsiders.com 

Displayed by this section of html:
      <td valign="middle">
        Edit <a href="userprefs.cgi">prefs</a>

        | <a href="relogin.cgi">Log&nbsp;out</a>&nbsp;user@company.com
      </td>
    </tr> 


When you perform a copy and paste of the email address (as I and other users 
frequently do), a space char is appended to the email address.  When you then 
paste this string into the "E-mail Address:" field to login, you get the error 
described above.

By changing the html to have the </td> flush with the end of the email address, 
a whitespace character would not be appended when performing the copy and 
paste, like:
      <td valign="middle">
        Edit <a href="userprefs.cgi">prefs</a>

        | <a href="relogin.cgi">Log&nbsp;out</a>&nbsp;user@company.com</td>
    </tr> 

Comment 2

15 years ago
isn't this a dupe of bug 161369 ?
(Reporter)

Comment 3

15 years ago
Yes, duplicate.  My repro is slightly different, however the fix described in 
161369 will address my repro.

*** This bug has been marked as a duplicate of 161369 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.