If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

position:fixed; parts rendered over the windows scroll bar

RESOLVED DUPLICATE of bug 183495

Status

()

Core
Layout: View Rendering
P2
normal
RESOLVED DUPLICATE of bug 183495
14 years ago
14 years ago

People

(Reporter: Christian Eyrich, Assigned: roc)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
After installing nightly 2003111808 on Win98 I discovered a painting problem
when viewing my homepage. The latest 20031028 I used before didn't show this
problem.
(Reporter)

Comment 1

14 years ago
Created attachment 135861 [details]
Testcase

This is a testcase to demonstrate the problem. I inserted a big table to
produce a vertical scrollbar. If you use the scrollbar or resize the window,
the headings background is painted over the scrollbar.

Comment 2

14 years ago
Strange.  I see the problem on the old 10/28 nightly - 2003-10-28-04 trunk on
Windows 2000, to be exact.

Comment 3

14 years ago
Sure looks a lot like bug 186696.
Indeed... The table doesn't have left:0, which is why it overlaps the scrollbar,
partially...
Depends on: 186696
Priority: -- → P2
(Reporter)

Comment 5

14 years ago
Hm, you're right, that looks very like bug 186696.
I only searched the last 3000 bugs because I didn't saw the problem with older
builds when visiting my homepage.
But more playing with my testcase made it also visible on 2003102505/Linux,
1.5/Win a.s.o.

If someone thinks it should not only depend on 186696 but duped, for all I care.

Updated

14 years ago
Keywords: testcase

Comment 6

14 years ago
This bug seems to be visible when position:fixed; is on an element with
width:100%; and a background-color. Removing the background-color and adding a
border for example does not show the bug. 

This is the same as bug 183495. Duping.

*** This bug has been marked as a duplicate of 183495 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.