[4.xP] ESC does not dismiss context menus

VERIFIED DUPLICATE of bug 20019

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 20019
18 years ago
18 years ago

People

(Reporter: Sean Richardson, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview:
Pressing the ESC key does not dismiss an active context menu (It does dismiss
an active normal menu (with issues, see bug 16944), or a dialog (in recent
builds - see bug 18446 for that)).

To Reproduce:
1. Right click on any link on any page to bring up a context menu
2. Press the ESC key.

Actual Results:
No result.

Expected Results:
The context menu is dismissed.

Does not work correctly with:
1999-12-23-08-M13 nightly binary on Windows NT 4.0sp3

Works correctly with:
Communicator 4.7 binary on Windows NT 4.0sp3
Explorer, Eudora, Explorer, Winzip, etc. on Windows NT 4.0sp3
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 1

18 years ago
Marking as a DUP of 20019, "Context (popup) menu fails to disappear on Esc",
M15 - although that bug may well be a DUP of bug 9157, "XUL Popup window should
be destroyed when ESC is hit".


*** This bug has been marked as a duplicate of 20019 ***

Comment 2

18 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.