Import of an Outlook 2003 address book crashes the program

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: bugzilla.20.mez, Assigned: Bienvenu)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.20 (Windows NT 5.1; U)  [en]
Build Identifier: 0.4a (20031110)

Whenever I try to import my Oulook 2003 address book, Thunderbird crashes after 
about two thirds of the data is processed. 

Reproducible: Always

Steps to Reproduce:
1. Tools -> Import
2. Address Books, OK
3. Outlook, Next

Actual Results:  
Crashed.


Windows gives the following Error Report data: ModName: import.dll ModVer: 1.6.
20031.11010 Offset: 0001bdbd.
(Reporter)

Comment 1

15 years ago
In the address book view, a new address book called "Contacts" is created,b ut 
it is empty.

Updated

15 years ago
Severity: major → critical
Keywords: crash

Comment 2

15 years ago
Just wanted to add that this happens to me with Outlook 98 as well.  I can
download and send mail, but I cannot import the Outlook 98 address book. 
Behavior the same. Using Thunderbird Release 0.4 downloaded today (Dec 6, 2003)
on Windows 2000 Pro (SP4). Thanks, Brian.
P.S. the below report is copied from Thunderbird forums, someone has the same
crash with Outlook 2000.
============
Posted: Thu 4th Dec 2003 2:42am     TB4rc2 crash on import Outlook address book
Thunderbird crashes when I try to import my address book from Outlook. When
restarting Thunderbird, it turns out an empty Address Book named "Contacts" has
been created (this is the correct name btw). Problem is reproduceable and was
also present with TB4rc1. I did set Outlook to be the default mail client (and
have executed this procedure many times succesfully with pre 4 versions in
combination with Outlook 2002).

Versions involved:
- Thunderbird 4 rc 2
- Outlook 2000
- Windows 2000 sp4

Misc info:
- Error message is "thunderbird.exe has generated errors and will be closed by
Windows..."
- My Outlook Contacts contains 733 items 
=================
(Reporter)

Comment 3

15 years ago
I figured out a bit more: I deleted all shortcuts to dates from my contacts and 
deleted the distribution lists as well, leaving only the contacts. Now it works! 

Comment 4

15 years ago
Same problem with WinXP Professional w/SP1, running - Mozilla Thunderbird 0.4 
(20031205). I deleted the 3 distribution lists I had and then was successful 
importing the Outlook 2003 adress book. Obviously it could not handle dist 
lists. Addresses and dist lists were originally created in Outlook 2000 
(Win2k), imported to Outlook 2003 then to Thunderbird. Each failure creates a 
new empty "Contacts" addressm book.

Comment 5

15 years ago
*** Bug 230052 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
I too had this problem. A workaround I found was to first export the Outlook 
2000 address book to Outlook Express.  Then I was able to import from Outlook 
Express into Thunderbird with no problem.

Comment 7

15 years ago
Windows XP Pro SP1 with Outlook 2002 produces same error.

Comment 8

15 years ago
Any chance to get a Talkback ID here? Run the program components/talkback.exe in
your Mozilla folder after sending the incident to get the ID.

Comment 9

15 years ago
This is probably a duplicate of bug 229401

Comment 10

15 years ago
Appears to affect Outlook 2000 as well.
(Assignee)

Comment 11

15 years ago
I tried a simple case of a contact and a distribution list, and didn't have a
problem. If anyone wants to e-mail me their Outlook.pst file, I have Outlook
installed now, so I can try it. I think you can export your address book to a
pst file, so you don't have to send me your whole outlook data file, but just
the address book. Thx.
Assignee: mscott → bienvenu
(Assignee)

Comment 12

15 years ago
this should be fixed in 1.7 now - empty distribution lists caused this, iirc.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 13

15 years ago
or tbird .7
You need to log in before you can comment on or make changes to this bug.