If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash whose cause in a broken/corrupt NC:color property in CalendarManager.rdf

RESOLVED WORKSFORME

Status

Calendar
General
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Frank, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

While trying to get rid of bug 198633 I found that CalendarManager.rdf is
broken! It is syntactically wrong *and* inconsitent mixing up two different ways
to save properties.

I will create two attachments, one with the original broken CalendarManager.rdf
and another with the fixed one. I xxx-ed out my passwords (see Bug 185340) and
some parts of the IP-adresses.

Reproducible: Always

Steps to Reproduce:
For now I don't know how to reproduce the corruption of CalendarManager.rdf.
But looking at least to bug 198633, you can see that other people have this
problem too.
Because CalendarManager.rdf stores the Calendars configuration, the only thing I
can advise for now is to add, modify and delete calendars for a while - just the
things I did...
Actual Results:  
CalendarManager.rdf is broken as described above and the following attachments

Expected Results:  
Don't break CalendarManager.rdf

I'm using "Mozilla 1.5 - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007" and "Mozilla Calendar 2003092614-cal" after upgrading from
Mozilla 1.3 and the previous calendar release using Windows XPpro

TB25759488X, TB25759312Z
(Reporter)

Comment 1

14 years ago
Created attachment 135901 [details]
Broken CalendarManager.rdf
(Reporter)

Comment 2

14 years ago
Created attachment 135902 [details]
Fixed CalendarManager.rdf

Comment 3

14 years ago
The attachments are not visible in Bugzilla.
(Reporter)

Updated

14 years ago
Attachment #135901 - Attachment description: Corrupt CalendarManager.rdf → Attachement not readable - see comments
Attachment #135901 - Attachment is obsolete: true
(Reporter)

Updated

14 years ago
Attachment #135901 - Attachment description: Attachement not readable - see comments → Broken CalendarManager.rdf
(Reporter)

Updated

14 years ago
Attachment #135902 - Attachment is obsolete: true
(Reporter)

Comment 4

14 years ago
So the attchements did not work(?), here they are as comments
Broken Calendar Manager.rdf:

<?xml version="1.0"?>
<RDF:RDF xmlns:JSLIB="http://jslib.mozdev.org/rdf#"
         xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Description about="urn:calendarcontainer:calendar1069165648565"
                   NC:serverNumber="5"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile5.ics"
                   NC:remote="true"
                   NC:username=""
                   NC:password=""
                   NC:name="Torsten Reuth"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/treuth.ics"
                   NC:publishAutomatically="false"
                   NC:active="true">
    <NC:color>#FFCC66</NC:color>
    <NC:color>#FFCC99</NC:color>
  </RDF:Description>
  <RDF:Description about="urn:calendarcontainer:calendar0"
                   NC:serverNumber="1"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\ffreund.ics"
                   NC:remote="false"
                   NC:active="true"
                   NC:name="Frank Freund"
                   NC:color="#FF9900"
                   NC:username="ffreund"
                   NC:password="xxxxx"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/ffreund.ics"
                   NC:publishAutomatically="false" />
  <RDF:Description about="urn:calendarcontainer:calendar3"
                   NC:username=""
                   NC:password=""
                   NC:name=""
                   NC:remotePath=""
                   NC:publishAutomatically="false">
    <NC:color></NC:color>
    <NC:color>#FFCCCC</NC:color>
  </RDF:Description>
  <RDF:Description about="urn:calendarcontainer:calendar1069178160516"
                   NC:active="true"
                   NC:serverNumber="5"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile5.ics"
                   NC:remote="true"
                   NC:username="ffreund"
                   NC:password="xxxxx"
                   NC:name="memoComp"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/memocomp.ics"
                   NC:publishAutomatically="false"
                   NC:color="#00CCCC" />
  <RDF:Description about="urn:calendarcontainer:calendar2"
                   NC:serverNumber="3"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile3.ics"
                   NC:remote="true"
                   NC:username=""
                   NC:password=""
                   NC:name="GermanHolidays"
                  
NC:remotePath="http://www.mozilla.org/projects/calendar/caldata/GermanHolidays.ics"
                   NC:publishAutomatically="false"
                   NC:color="#CCCCCC"
                   NC:active="true" />
  <RDF:Seq about="urn:calendarcontainer">
    <RDF:li resource="urn:calendarcontainer:calendar0"/>
    <RDF:li resource="urn:calendarcontainer:calendar2"/>
    <RDF:li resource="urn:calendarcontainer:calendar3"/>
    <RDF:li resource="urn:calendarcontainer:calendar1069165648565"/>
    <RDF:li resource="urn:calendarcontainer:calendar1069178160516"/>
  </RDF:Seq>
</RDF:RDF>
(Reporter)

Comment 5

14 years ago
Fixed CalendarManager.rdf

<?xml version="1.0"?>
<RDF:RDF xmlns:JSLIB="http://jslib.mozdev.org/rdf#"
         xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Description about="urn:calendarcontainer:calendar1069165648565"
                   NC:serverNumber="5"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile5.ics"
                   NC:remote="true"
                   NC:username=""
                   NC:password=""
                   NC:name="Torsten Reuth"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/treuth.ics"
                   NC:publishAutomatically="false"
                   NC:active="true"
		   NC:color="#FFCC99" />
  <RDF:Description about="urn:calendarcontainer:calendar0"
                   NC:serverNumber="1"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\ffreund.ics"
                   NC:remote="false"
                   NC:active="true"
                   NC:name="Frank Freund"
                   NC:color="#FF9900"
                   NC:username="ffreund"
                   NC:password="xxxxx"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/ffreund.ics"
                   NC:publishAutomatically="false" />
  <RDF:Description about="urn:calendarcontainer:calendar1069178160516"
                   NC:active="true"
                   NC:serverNumber="5"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile5.ics"
                   NC:remote="true"
                   NC:username="ffreund"
                   NC:password="xxxxx"
                   NC:name="memoComp"
                  
NC:remotePath="http://192.168.xxx.xxx/webdav/calendars/memocomp.ics"
                   NC:publishAutomatically="false"
                   NC:color="#00CCCC" />
  <RDF:Description about="urn:calendarcontainer:calendar2"
                   NC:serverNumber="3"
                   NC:path="K:\Profile
data\Mozilla\ffreund\k903smh1.slt\Calendar\CalendarDataFile3.ics"
                   NC:remote="true"
                   NC:username=""
                   NC:password=""
                   NC:name="GermanHolidays"
                  
NC:remotePath="http://www.mozilla.org/projects/calendar/caldata/GermanHolidays.ics"
                   NC:publishAutomatically="false"
                   NC:color="#CCCCCC"
                   NC:active="true" />
  <RDF:Seq about="urn:calendarcontainer">
    <RDF:li resource="urn:calendarcontainer:calendar0"/>
    <RDF:li resource="urn:calendarcontainer:calendar1069165648565"/>
    <RDF:li resource="urn:calendarcontainer:calendar1069178160516"/>
    <RDF:li resource="urn:calendarcontainer:calendar2"/>
  </RDF:Seq>
</RDF:RDF>
(Reporter)

Comment 6

14 years ago
Copying comment4 and comment 5 to a XML-editor, results in greatly improved
readabilty...

Updated

14 years ago
Attachment #135901 - Attachment mime type: text/rdf → text/plain

Updated

14 years ago
Attachment #135902 - Attachment is obsolete: false
Attachment #135902 - Attachment mime type: text/rdf → text/plain

Updated

14 years ago
Attachment #135901 - Attachment is obsolete: false

Comment 7

14 years ago
The attachement problem was the mimetype which must be text/plain and not
text/rdf for an rdf to be seen and not interpreted by the browser. We learn
something there.
Concerning the bug itself. It seems that the bug arises from the color statement.
I remember that I modified by hand my calendarManager.rdf a long time ago : It
could be that this corruption occurs during the experimental period when the
coloring code as been introduced in calendar (Spring 2003).
Was your calendarManager.rdf an old file ?
Does the corruption could have occurs during the introduction of the coloring code ?
(Reporter)

Comment 8

14 years ago
Yes, my CalendarManager.rdf was an old file, I tried Calendar from time to time
since around a year at least. But till my previous calendar update some days ago
it worked at least without crashes. The "phantom calendar" (see bug 198633) and
the broken CalendarManager.rdf occured *after* upgrading to "Mozilla Calendar
2003092614-cal". And I switched a lot of color codes till then :-)
If needed I can dig our backuptapes for a CalendarManager.rdf prior to the
mentioned calendar upgrade. But this will take some days...

Comment 9

14 years ago
Thanks Frank for your investigations. I changed the summary to include the
NC:color problem. I propose to leave it as UNCONFIRMED for now, and wait more
informations from you or somebody else.
Summary: CalendarManager.rdf is broken/corrupt → Crash whose cause in a broken/corrupt NC:color property in CalendarManager.rdf
This issues seems to be no more?

Comment 11

13 years ago
Thanks Martin.
It seems that this bug has not been observed for a long time now. The bug has
been observed when the calendar color settings has been introduced and be
corrected now.
I mark it has WORKSFORME Please reopen if necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.