Bookmarks on personal toolbar display error due to selected folder gfx height problem

VERIFIED FIXED in M14

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Matthew Kerr, Assigned: David Hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand. Needs review.)

(Reporter)

Description

18 years ago
The bookmark menu next to the "Home" and "Mozilla.org" buttons, not off the menu
bar with view, search, go, etc, has strange display problems if you pass your
mouse cursor over it. What seems to be happening is that the selected bookmark
folder highlight is larger height wise than it should be by a few pixels, and it
also bumps the other areas around a bit perhaps adding a few pixels height in
other bookmark folders it has already passed by with this graphical bug.

I'm using Win32 build 1999122308.

Comment 1

18 years ago
Confirmed on NT and Linux. The highlighted item on the Personal Toolbar
Bookmark Menu is a bit taller than the unhighlighted items, causing a
nifty-yet-disconcerting rippling effect when the mouse pointer is run
up and down the menu.

Tested with:
1999-12-25-08-M13 nightly binary on Windows NT 4.0sp3
1999-12-25-08-M13 nightly binary on Redhat Linux 6.1 (gnome+enlight)

I'm sure I've seen this reported before, possibly as an XP Toolkit/Widgets
or XPMenus bug.

Updated

18 years ago
Assignee: slamm → saari
Component: Bookmarks → XPMenus

Comment 2

18 years ago
Chris, looks like some menu fun for you ...

Updated

18 years ago
Target Milestone: M15

Updated

18 years ago
OS: Windows 98 → All
Hardware: PC → All

Comment 3

18 years ago
as expected this bug is XP and still exists on all platforms as of 2000011 builds.
Assignee: saari → trudelle
this has nothing to do with menus, but css i bet. reassigning to trudelle for
better triage.

Comment 5

18 years ago
hey pink, this is the bug I've been looking for for a while. There are a bunch of bugs floating around about
the BM(on the Ptoolbar) menu jittering and other wierd behavior. This sounded like one of the most likely causes. which bugs?
well how about bug 20518, bug 24340, bug 21262, and bug 21477 for starters!

Updated

18 years ago
Summary: Bookmark menu display error due to selected folder gfx height problem → Bookmarks on personal toolbar display error due to selected folder gfx height problem

Comment 6

18 years ago
cc'ing slamm as i'm trying to get some of these similar problems all under one roof.

Comment 7

18 years ago
*** Bug 24340 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: trudelle → hyatt

Comment 8

18 years ago
This is not limited to the bookmarks menu, it happens the first time that a
submenu of any personal toolbar menu is displayed.  What seems to be happening
is that the spacing (leading?) below the parent menu item is increased when the
submenu is first displayed, and retained on subsequent display of the parent
menu. reassigning to hyatt, who says he wants to keep this one.

Comment 9

18 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
(Assignee)

Comment 10

18 years ago
This is a dup of 20518.


*** This bug has been marked as a duplicate of 20518 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

18 years ago
Oops, wrong. These were different.
Status: RESOLVED → REOPENED
(Assignee)

Updated

18 years ago
Resolution: DUPLICATE → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 12

18 years ago
The template was building menus with bad attributes on them.  Shame.  I fixed 
it and now have a navigator.xul that behaves wonderfully with these menus.
Whiteboard: Fix in hand. Needs review.
Target Milestone: M15 → M14
(Assignee)

Comment 13

18 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
VERIFIED fixed with 2000020108 WinNT build
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: claudius → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.