Status

RESOLVED DUPLICATE of bug 59075
15 years ago
14 years ago

People

(Reporter: dreamcoder, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

There should be a plug-in for Macromedia Flash or Shockwave. Instead of users
getting it self.

Reproducible: Always

Steps to Reproduce:
1. Go to Macromedia Website
2. Download Flash or Shockwave
3. Install the software

Actual Results:  
It worked. Then i got Flash to work. 

Expected Results:  
Put in a plug-in for Flash/Shockwave in the browser.

Using MoZilla 1.6a
No theme.

Comment 1

15 years ago
@reporter:
when reporting bugs, could you please try to make the summary useful? Having a
subject that simply says 'Flash Plugin' is like reporting a bug that simply says
'Crash' in the summary - it doesn't give a reader the slightest idea what the
bug is about, and additionally it makes it hard to query for it in bugzilla.

Since Flash is not free software and owned by Macromedia, I guess you are
suggesting that the Mozilla Foundation negotiate a distribution deal with
Macromedia to allow Mozilla to ship with their proprietary product included?

I suspect this is either WONTFIX or INVALID, depending on whether or not such a
deal is at all possible.

Comment 2

15 years ago
I won't close this because I'm not 100% certain the policy hasn't changed, but
the identical bug 59075 was marked wontfix. The reason given is that Mozilla
doesn't want to/can't bundle a program that is incompatible with the Mozilla
Public License (MPL). Although I've heard talk of a default plug-in pack for
Firebird so I'm a little unsure where things are headed in that regard.

Comment 3

15 years ago
In addition to the license problem:

If I understood the OP correctly, he requested that the Mozilla distribution
(not a separate plugin pack!) contain the plugin - see the part "Instead of
users getting it self.".

This is rather short-sighted, I believe: normally, you only download a plugin
once, and then have it available until an updated version is released. OTOH, a
lot of people download new releases of Mozilla very frequently. Those people
would be punished with the additional download data volume each time they update
their Mozilla. To make matters worse, by extension, Mozilla should then also
include RealPlayer, nppdf, the Java-Plugin, etc. - this is clearly not feasible.

A separate plugin pack would be acceptable from this perspective, but the
original problem remains: the owners of the plugin have to agree, and license
conflicts need to be avoided.

*** This bug has been marked as a duplicate of 59075 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
In 12 months there have been 20 alpha, beta and final releases of Mozilla, plus
5 Release candidates. Counting the finals only, 1.0.1 for HP-UX through 1.5,
there are still 11 releases. Netscape released once or at most twice a year.
Including Java alone will double the size of Mozilla, thats not feasible for
people with a 56k line, or worse. 
Packing together Plugins in one separate pack will force people to download the
whole pack, even if one component only has changed, and components change pretty
fast, if you look at Macromedia and Sun.
Those who want the latest Adobe plugin surely also want the latest Adobe Reader,
thats another 15MB.

I don´t think a plugin pack would be feasible, it must be changed pretty often,
and there may be legal problems to be solved again if a company changes ownership.
Imho http://plugindoc.mozdev.org/ is the best solution, giving advice and links
 for getting and installing plugins for a lot of operating systems, including
Windows.
Reading the first page coming up after installing:
http://www.mozilla.org/start/1.5/
you should find this link titled 'Plug-ins', if you are interested:
http://www.mozilla.org/start/1.5/plugins.html
It redirects you to a mozdev.org plugin page specific to your operating system.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.