Channel name with a slash cannot be joined

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Per Johansson, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patch, URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; sv-SE; rv:1.5) Gecko/20031017
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; sv-SE; rv:1.5) Gecko/20031017




Reproducible: Always

Steps to Reproduce:
1. Open irc://irc.be.webbnet.info/
2. In the command field, type "/j os/2"

Actual Results:  
[ERROR]	Internal error dispatching command “join”.
[ERROR]	[Exception... "Component returned failure code: 0x80520001
(NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIFile.append]" nsresult: "0x80520001
(NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame ::
chrome://chatzilla/content/prefs.js :: getChannelPrefManager :: line 215" data: no]

Expected Results:  
Opened the channel #os/2. The other channels on the network work.

Comment 1

14 years ago
All sorts of things go wrong here...

The / kills the logging, throwing NS_ERROR_FILE_UNRECOGNIZED_PATH.
You *do* actually join the channel (look at /whois).
Clicking the link in /whois, however, displays a dialog saying it's an invalid
IRL URL, but has %S instead of the URL.
The console logs this: "parseIRCURL: rest split failed “/%23testing/42” "
And you can't easily leave it, because /leave "must be run in the context of a
channel" dispite allowing a channel name paramter.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
OS: other → All

Comment 2

14 years ago
Created attachment 142298 [details] [diff] [review]
Escape "-" in regexp character class

This regexp was not escaping "/" (among other characters) because it fell into
the range created by "#-_". Escaping the "-" makes channels with "/" in them
work fine here, though there may be other issues not yet found.

Updated

14 years ago
Whiteboard: cz-patch

Updated

14 years ago
Attachment #142298 - Flags: review?(samuel)

Updated

14 years ago
Attachment #142298 - Flags: review?(samuel) → review+

Comment 3

14 years ago
Comment on attachment 142298 [details] [diff] [review]
Escape "-" in regexp character class

Checked in.

Comment 4

14 years ago
The patch just checked in should fix the logging error described. I believe that
was the only issue with joining channels with a slash in them. If so, please
mark this bug FIXED.

Comment 5

14 years ago
Ack, regression. % is now being escaped... to %25. This has changed log
filenames from %23channel to %2523channel.

Comment 6

14 years ago
Created attachment 144184 [details] [diff] [review]
Stops it escaping % for file names.

Comment 7

14 years ago
Comment on attachment 144184 [details] [diff] [review]
Stops it escaping % for file names.

Stops it escaping the % escpaes. :)
Attachment #144184 - Flags: review?(samuel)

Updated

14 years ago
Attachment #144184 - Flags: review?(samuel) → review+

Updated

13 years ago
Depends on: 255081

Comment 8

13 years ago
ChatZilla 0.9.65 has landed. I believe this bug is fixed now; if it is not
fixed, please re-open the bug stating why you don't believe it's fixed.

Until an XPI is made of 0.9.65, 0.9.64g will do as for testing as it is
basically the same codebase.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.