that page resizes mozilla browser ???

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: skliaroukp, Assigned: vidur (gone))

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
that page resizes mozilla browser ???

Expand mozilla full-screen, go to that page and see
browser window to shrink (vertically).
The onLoad attribute on BODY looks like the cause here.  Is this a CAPS issue?

Updated

18 years ago
Assignee: nobody → vidur
Component: Browser-General → DOM Level 0
QA Contact: nobody → desale

Comment 2

18 years ago
Te resizing certainly looks intentional: here is the content of the BODY onload:
   >onLoad="if (navigator.appName.indexOf('Netscape') != -1)
   >{resizeTo(window.innerWidth-1,window.innerHeight-1)}"
If it worked properly, this would be expected...

On the other hand, each time the [Jobs] button is clicked, the page gets
shorter vertically, and the horizontal size never changes. I don't know
javascript, but resizeTo is not defined in the script on the page, so,
assuming that it is a built-in function, there may be a javascript problem
(I'd have expected the same size each time, if window.innerWidth and
window.innerHeight are based on the size of the contents).
None of this happens with 4.x or IE5.

Tested with:
1999-12-25-08-M13 nightly binary on Windows NT 4.0sp3
Communicator 4.7 on Windows NT 4.0sp3
IE5 on Windows NT 4.0sp3

I don't know enough to say whether this could be a "Javascript Engine" problem
or a "DOM Level 0" problem; trying the latter Component.

Comment 3

18 years ago
Created attachment 3901 [details]
Reduced test case for browser dimension issue

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Whiteboard: [TESTCASE]

Comment 4

18 years ago
The test case (id=3901 job.html) contains the onLoad code that changes the
browser size and an alert which displays the values for innerHeight, innerWidth,
outerHeight, outerWidth.

The code will reduce the browser size from outerWidth by outerHeight to
innerWidth-1 by innerHeight-1 (resizeTo takes the new outer Width and Height as
arguments).  This appears to work as expected (build 1999123008) given the
returned values for innerHeight and outerHeight.

However, this is not working as expected in Navigator 4.x.  Nav 4.05 only
decreases the dimensions by 1.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Verified. Behaviour is expected because resizeTo is being called. Invalid.
You need to log in before you can comment on or make changes to this bug.