Messages displayed as empty, despite having a significant size

RESOLVED DUPLICATE of bug 249195

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 249195
15 years ago
10 years ago

People

(Reporter: Jonathan Mills, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

Occurs infrequently, - I connect to my IMAP server over a ISDN (64Kbps)
connection, and have fairly large amounts of mail.

Sometime - and I suspect it's connected with doing something  - like looking at
a messages, or the link breaking (a rare event) - I end up with a message which
has a size (the one I am looking at now is reported as 135K - about right), but
when I click, the message text window is blank.

Reproducible: Sometimes

Steps to Reproduce:
1. not quite sure - seems to happen at odd time, may be
2. connect. Mail starts to download over the slow link
3. see an interesting message - click to read
4. later, find another messga ei s blank

Actual Results:  
message text is absent

Expected Results:  
dispayed the message

I could live with a work around to either
1) invalidate the cached copy of the message (which I suspect is damaged)
or
2) Get a message which has already been downloaded

If I did invalidate the whole message store, the message comes down - but I have
so uch mail this is 2 hours over a slow link.

Comment 1

15 years ago
I am expieriencing this problem, too. But I cannot yet recognize any pattern in
which mails are affected. About 1 of 200 mails have this problem. Even
restarting mozilla won't help immediately. Occurs in both Win2k and Linux. 
(Assignee)

Comment 2

15 years ago
can you try tomorrow's 1.6b build and let me know if this still happens? thx.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
I've recently started seeing this too. Running trunk build 2004061507 on WinXP,
UW IMAPD server. No other clients running.

Looks like an empty message was cached when junk mail controls were run. Size
column shows the correct size, but the message is empty (as shown by the message
source). The following error is logged in JS console:

Error: [Exception... "Component returned failure code: 0x80004003
(NS_ERROR_INVALID_POINTER) [nsIMsgMailNewsUrl.mimeHeaders]"  nsresult:
"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://messenger/content/mailWindowOverlay.js :: HandleMDNResponse :: line
2151"  data: no]
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 2151

Restarting Mozilla helps in this case.
(Assignee)

Comment 4

14 years ago
Ere, is there anything special about these messages, e.g., no message-id? Can
you e-mail me a protocol log? Thx.

Comment 5

14 years ago
Nothing special with the messages. I just had left Mozilla running for the night
and now when I came back to the system and read bugmail there were multiple
empty messages. Unfortunately I managed to destroy the log so I'll have to wait
for it to happen again (shouldn't take too long).

Comment 6

14 years ago
A protocol log sent via email.
(Reporter)

Comment 7

14 years ago
This isn't quite the same as I originally reported - in my case if you leave Moz
along
it works.  the problem I have is when I connect over broadband / or slower, and
it downloads the headers.
It then starts downloading the bodies of the messages.  I however, see a message
header that I want to see and click on it ... often, I then never get to see the
content - I can't recall whether it the contents of the one I click, or the
conents of the one it was downlaoding before.

I recently upgraded to broadband (512kbps), and it happens less frequently than
it did when I have only 64kb/s

I suspect I now have a work-around too - delete the message and then undelete it
....

Jonathan

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 249195 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.