Error establishing an encrypted connection after requesting a new certificate, error # -8075

VERIFIED INVALID

Status

()

Toolkit
Password Manager
--
blocker
VERIFIED INVALID
15 years ago
10 years ago

People

(Reporter: Asier Azaceta, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

After requesting a client certificate (PKI) from a CA and setting up a password
for the Software security device (NSS PKCS #11), I cannot see any https url,
gettin always the "Error establishing an encrypted connection" message with
error number -8075. I've tried with and without logging into the Software
security device, I've even removed the password and restarting the browser
without any success. I'm completely blocked here, I'll have to discard the
browser and the certificate request which has already been procesed; but I can't
download the certificate as it's an https page :-(

Reproducible: Always

Steps to Reproduce:
1.Request a certificate from a CA (my case http://www.cert.fnmt.es)
2.Setting up a password for the Software Security Device
3.Trying to access an https url after closing and opening the browser
4.You can try loggin manually into the SSD

Actual Results:  
You get an error message box: "Error establishing an encrypted connection to
<url>. Error code: -8075"

Expected Results:  
Establishing the SSL connection and opening the site

none
(Reporter)

Comment 1

15 years ago
Created attachment 135979 [details]
Error message box

Just for clarification
(Reporter)

Comment 2

15 years ago
Previously to the actions commented in the bug I downloaded & installed the root
certificate for the CA I was requesting the certificate at, as it was not one of
the built in.
Now it's added as a Software Security Device CA. I've tried to revome it, but it
doesn't solve the problem.
The CA is located at http://www.cert.fnmt.es
The CA cert can be downloaded at:
http://www.cert.fnmt.es/certificados/FNMTClase2CA.crt

I will attach an screenshot from my CAs.
Thanks in advance.
(Reporter)

Comment 3

15 years ago
Created attachment 135980 [details]
Screenshot of my CAs

This shows my CAs after installing the new CA root certificate
(Reporter)

Comment 4

15 years ago
PROBLEM "SOLVED": it was not related with the CA or the Soft Sec Device, it was
related to something I also changed: I chose to use OSCP using Verisign for
validating certificates. Obviously I did something wrong or something is broken
there, but it's not related to all the text in this bug. If I discover anything
I will open a new bug report on the subject. Thanks a lot anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
v.
Status: RESOLVED → VERIFIED
Group: security
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.