If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla download shows incorrect file size for large files

RESOLVED DUPLICATE of bug 184452

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 184452
14 years ago
9 years ago

People

(Reporter: Nate Bingel, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Mozilla download shows incorrect file size for large files.  I was downloading a
2.1 GB file which translates to 2168934.4 KB but Mozilla displayed a negative
number instead.


Reproducible: Always

Steps to Reproduce:
1.Download a Large file around 2GB
2.Watch the progress dialog.
3.

Actual Results:  
The Progress dialog is display the incorrect number of KB.

Expected Results:  
Use a large data type to represent the download size.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.