If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

error message at startup: "Error launching browser window: no XBL binding for browser"

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: David Simcha, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031121 Firebird/0.7+

When I attempt to start Mozilla Firebird for Win32 11/20 or 11/21 builds (Note
that since there were no official 11/20 builds, I was using an unofficial one),
I receive the error message  "Error launching browser window:  no XBL binding
for browser".  After clicking okay, the browser window stays, I can click the
menus, and the Windows buttons (Maximize, etc.) work.  However, no response is
generated when I click on any toolbar buttons or type anything in the location
bar and press enter.

Reproducible: Always

Steps to Reproduce:
1.  Install Mozilla Firebird 11/20 or 11/21 build for Win32 under WinXP SP1. 
Note that since there were no official Win32 builds for 11/20, this was an
unofficial build from some forum, compiled with MSVC optimized for SSE.  The
11/21 build, however, was official.   The bug is the same whether the zipped or
installer version is used.
2.  Launch this version of Mozilla Firebird.
3.

Actual Results:  
I received the error message  "Error launching browser window:  no XBL binding
for browser" and the browser did not function.

Expected Results:  
functioned normally

Comment 1

14 years ago
This is due to the change from bindings back to widgets (or is it the other way
around, I can never remember). Themes/extensions need to be updated, or they
will give this error. --> INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.