If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

apexguitars.com - Navigation links only work in IE

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Ben Basson, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

On all pages at http://www.apexguitars.com/, some of the navigation links are
proken. If you hover over them, they contain lots of really bizarre syntax
errors, examples follow:

"http://www.apexguitars.com/pageview2.asp?nav=<id98><h6>CONTACT US&cust=176"
"http://www.apexguitars.com/pageview2.asp?nav=<id8><h6>GUITAR STRINGS&cust=176"

Why anyone would put h6 tags in their navigation urls is quite beyond me...
however as IE basically accepts any buggy code... it somehow works (dont know
about IE5....but it does in IE6). Mozilla Firebird gets the following error
every time:

Microsoft OLE DB Provider for ODBC Drivers error '80040e09'
[TCX][MyODBC]You have an error in your SQL syntax near '' at line 1
/mailforms/mailform2.asp, line 24

However, using IE, I get no errors. I highly doubt that Mozilla Firebird has
problems with accessing these types of sites normally, and I assume it's the
messed up href locations that is causing the problem.

I've filed this as OS "all" and hardware platform "all". I have no way of
testing either of these, but I assume it's not relevant anyway.

Reproducible: Always

Steps to Reproduce:
1. Load the site http://www.apexguitars.com/ in Mozilla Firebird (I'm on 0.6.1,
I assume this is irellevant).
2. Click on the nav links (some work, some dont... all work in IE though).


Actual Results:  
Following error is shown:

Microsoft OLE DB Provider for ODBC Drivers error '80040e09'
[TCX][MyODBC]You have an error in your SQL syntax near '' at line 1
/mailforms/mailform2.asp, line 24

Expected Results:  
It should have loaded the pages I requested by clicking the links.

If they wont listen, I'll visit the shop every morning and tape "Support Web
Standards" banners to their front window.

Comment 1

14 years ago
This page WFM FB 0.7 i686 Linux.  It is rather messed up source though.
(Reporter)

Comment 2

14 years ago
Checking back later, problem is still present.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Summary: Navigation links only work in IE → http://www.apexguitars.com - Navigation links only work in IE
(Reporter)

Comment 3

14 years ago
Problem still present in 0.8 and Mozilla 1.6, contacting VISAV, the responsible
company for the production of this website.
(Reporter)

Comment 4

13 years ago
This is now fixed, since the entire design and underlying structure has been
updated.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 5

13 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: http://www.apexguitars.com - Navigation links only work in IE → apexguitars.com - Navigation links only work in IE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.