All users were logged out of Bugzilla on October 13th, 2018

FreeBSD M12 binary non-working

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: kiel, Assigned: pete)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Please direct this to the best person:  The FreeBSD binary in the M12 release
area can not be run, because it is linked to some libraries that aren't in the
distribution or on most systems (libintl.so).  If it isn't presumptuous to think
other people probably can't get it to work either because of this, in the url is
a package that works fine on all of my systems.

If there is a special way to package releases, let me know (or fix this or
however).  I will attach some build and install hints as well if someone might
find them useful.
(Reporter)

Comment 1

19 years ago
Created attachment 3818 [details]
build hints for freebsd systems
(Reporter)

Comment 2

19 years ago
Created attachment 3819 [details]
install hints for attached binary

Updated

19 years ago
Assignee: leaf → pete
(Assignee)

Comment 3

19 years ago
I did the binary build here on my 3.2 release box.
Which ran fine on two other 3.3 release boxes.
In fact yesterday i ran it on a freshly installed 3.3 box with no mozilla
sources just gtk and glib.

When things stablize a little more these packages will improve and we will
hopefully get a port up and running to build from source. Because as it stands
right now there is one patch i am using to build the source on 3.x versions to
work around the dll loader prob.

Thanks for all the feedback and help.

pete

(a fellow freebsder)
(Reporter)

Comment 4

19 years ago
It's dependent on installing the info files distribution for some reason though.
Kinda goofy.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 5

19 years ago
*** Bug 25542 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
mass re-assign of all bugs where i was listed as the qa contact
QA Contact: cyeh → chofmann

Comment 7

19 years ago
Is this still an issue? Or can this bug be closed as a non-issue?
(Reporter)

Comment 8

19 years ago
It's still a problem as of the M15 release.  The binary is dependant on 
installing the optional and unrelated info files distribution.

Comment 9

19 years ago
Works for me:
FreeBSD-current
nightly source tarballs and CVS pulls

Comment 10

18 years ago
This bug is really old, shouldn't it get cleared out because it really isn't useful?

(sorry for spam)

Comment 11

17 years ago
May be marked FIXED as there're now recent (0.9.4) binary FreeBSD releases.
However, similar "recent" bugs exist: see bug 92400.
reporter: are you still seeing this with a recent version of mozilla?

Comment 13

17 years ago
ldd mozilla-bin shows it doesn't link to libintl. and recent freebsd binaries
work fine. maybe this dated bug could be closed. 

Comment 14

17 years ago
resolving (pete, feel free to spank me if I'm out of line)
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.