not possible to choose preferences directory other than %AppPath% in Windows

RESOLVED DUPLICATE of bug 211628

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 211628
15 years ago
15 years ago

People

(Reporter: atheklinux, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When Firebird runs for the first time in Windows, it creates a directory
"%AppPath%/User/Application Data/Phoenix/Profiles/[random string].slt" to
contain the user profile, as well as .dat files such as registry.dat under
"%AppPath%/User/Application Data/Phoenix"

The user should be able to specify where Mozilla Firebird saves and looks for
settings.

Reproducible: Always

Steps to Reproduce:
1. Download a Firebird build
2. Extract to any directory
3. Run MozillaFirebird.exe



I found this out while I was trying to run Firebird from a network partition,
designated as Y:\. While I could get certain settings to be saved on the network
partition, there was always something saved on the local machine. This was a
problem when logging in to other machines, which would then always create a new
profile on the local hard drive and, specificall, on C:\. I was attempting to
get it to save every bit of data on Y:\ so it wouldn't matter which machine
Firebird ran on, it would always keep its settings.

Comment 1

15 years ago
When you first run FB use the -profilemanager switch.  You should be able to
choose which folder to keep your settings in.  If this is what you're referring
to, please close this bug.
(Reporter)

Comment 2

15 years ago
Using the -profilemanager or -p switch doesn't fix the problem; even when
creating a profile in a place of my choosing, Firebird still creates the
directory "C:\Documents and Settings\User\Application Data\Phoenix\Profiles". It
also creates the two files pluginreg.dat and registry.dat in the "Phoenix"
directory.

As far as I know, this isn't changeable now but those files and directory
locations are what I think should be made possible to change.
(Reporter)

Comment 3

15 years ago
Here's a more detailed example of what this feature would achieve/solve:

1. Two PCs are networked and both have access to network drive Y:\
2. Firebird is located at "Y:\Firebird"
3. Firebird is run on PC #1, and a profile is created at
"Y:\Profiles\Firebird\Default", on the network drive.
4. When it is run on PC #2, Firebird cannot recognize the profile is at
"Y:\Profiles\Firebird\Default" so it defaults to "%AppPath%\User\Application
Data\Phoenix\Profiles\" on the local machine.

Comment 4

15 years ago
This is already possible. You need to start with MozillaFirebird.exe on PC#2
with the -P switch. You can delete the existing default profile, and create a
new one. If the profile you want is at:

Y:\Profiles\Firebird\Default\[random].slt

Then you need to create a new profile (yes, create a new one, but it will use
the existing one if there is already one there), called Default, and tell it to
create it in the following location:

Y:\Profiles\Firebird\

Both PCs will then be able to use the same profile. The pluginreg.dat and
registry.dat are not part of the profile, and are supposed to be different on
different systems. This is by design.

CAVEAT: Note that you should not use the same profile on both machines at the
same time. That will likely cause problems, and is unsupported.

Also, backup your profile before attempting this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
These suggestions don't quite solve the problem I'm trying to solve.

Say I create a Mozilla Firebird profile for John on drive Y.

1. John logs on and runs Firebird.
2. When he runs Firebird, it still looks on drive C for registration files in
order to find the profile.

My goal is to move everything off C: if possible, including those registration
files.

Comment 6

15 years ago
Okay, I'm not sure about this. Am reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

15 years ago
This bug is the Mozilla Firebird duplicate of bug 211628.  I'm going to hazard a
guess that fixing that bug will fix this bug.  If it doesn't, I'm sure the
capability will enter Mozilla Firebird soon after bug 211628 is fixed.

This is also mentioned in Asa Dotzler's (big Mozilla head honcho) notblog. 
Based on the comments there, it appears that bug 211628 is indeed this bug's
duplicate.  Here's the link to the entry:

http://weblogs.mozillazine.org/asa/archives/004435.html

In the entry's comments, a perhaps-helpful URL is mentioned.  Check it out, as
it might help (or it might not - I haven't tried it out):

http://www.alain.knaff.lu/howto/MozillaCustomization/

*** This bug has been marked as a duplicate of 211628 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.