indenting <DD> without an enclosing <DL> is wrong

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: illich, Assigned: buster)

Tracking

({compat, testcase})

Trunk
Future
x86
All
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
If I make new paragraph with: <DD><P ALIGN=JUSTIFY> it's wrong. It should make a
paragraph, which has first line intended (i'm not sure, if it is the right word)
and the text aligned to both edges. Neither of those two effects appear.

Updated

19 years ago
Summary: paragraphs → [4.xP] justified paragraphs

Comment 1

19 years ago
The entire content of <DD> is indented in WindowsNT. I believe this is correct;
I haven't found anything to the contrary. Could you please be more specific
about the rendering in Linux?


The text justification doesn't work--I'm marking this as "4.xP" and changing the
summary to reflect the problem. I hope there is no problem with these changes?

Comment 2

19 years ago
Created attachment 3839 [details]
2 Justified paragraphs - w/ align= and w/ CSS text-align
Created attachment 3841 [details]
Testcase showing <DD> indentation problem
OS: Linux → All
Summary: [4.xP] justified paragraphs → [4.xP] indenting <DD> without an enclosing <DL> is wrong
Whiteboard: [TESTCASE]
Text justification problem is a duplicate of bug 588.

I disagree with fantasai@escape.com; in my opinion <DD> should not be indented
if it isn't enclosed in a <DL>.
They should probably behave more like <LI> without <UL>/<OL>.
IE5 and Nav4.x does not indent (the entire) <DD> when it's not within a <DL>.

Changing summary to reflect <DD> indentation problem instead of justification.

Comment 5

19 years ago
I see your point, but should Mozilla encourage or discourage this practice?
MSIE stopped indenting the whole paragraph only with version 4.0 --
2.0 and 3.0 behave like Mozilla does now, as do Mosaic 3.0, Amaya 2.1, and Opera
3.6 (I just tested them all.)

Is <DD> for indentation widely used? This is my first encounter. Certainly this
interpretation is not widely supported.

Maybe this issue should be taken up by the layout newsgroup as well...

Updated

19 years ago
Assignee: rickg → kipp

Comment 6

19 years ago
This document is well formed. The problem is in layout. Reassigning to buster.
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 7

19 years ago
seems like there are two problems reported here, one having to do with text
justification and one having to do with the interpretation of DD.  The text
justification is the more ijmportant problem so let's tackle that here.
Adding [TEXT] M15.

Comment 8

19 years ago
Bug 5119 dealt with a similar issue, but the HTML was coded in a slightly different
manner. Do we want to go down this path further and implement this variation as
well?

Personally, I say there's bigger fish to fry than this one.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase

Comment 10

19 years ago
Setting the keyword all open [4.xp] bugs to 4xp.
Keywords: 4xp

Updated

19 years ago
Summary: [4.xP] indenting <DD> without an enclosing <DL> is wrong → indenting <DD> without an enclosing <DL> is wrong
Whiteboard: [TESTCASE]

Comment 11

19 years ago
Same problem on this page: http://aviation-safety.net/
(Assignee)

Comment 12

19 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster

Comment 13

19 years ago
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16
(Assignee)

Comment 14

19 years ago
Won't make beta2 if it stays on my list.  Moving to M18.
Status: NEW → ASSIGNED
Target Milestone: M16 → M18
Is DD without an enclosing DL even valid HTML? Low priority if bad HTML. How 
common is this practice? If invalid, recommend marking FUTURE unless extremely 
widespread on the web.
It's not valid HTML.  However, it *may* be easy to fix in the quirks-mode
html.css file (at the cost of a little performance, as is everything in any
html.css file).  It would probably be similar to the solution for bug 1049.  I
might have a chance to figure out the necessary rules sometime in the future.
(Assignee)

Comment 17

18 years ago
redistributing bugs across future milestones, sorry for the spam
Target Milestone: M18 → M19
(Assignee)

Comment 18

18 years ago
based on Eric's comments...

This bug has been marked "future" because we have determined that it is not 
critical for netscape6.0. 
If you feel this is an error, or if it blocks your work in some way -- please 
attach your concern to the bug for reconsideration.
Target Milestone: M19 → Future
I would strongly recommend marking this WONTFIX, not Future.
Keywords: 4xp → compat

Comment 20

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca
Both problems, text justification and indentation of <DD>, seems to be fixed
now, using build 2000-11-04-20 on Windows NT4 sp6. WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 22

18 years ago
Seems to be working for me also, NT 11-04-09.  VERIFIED.
Status: RESOLVED → VERIFIED

Comment 23

18 years ago
Text justification was fixed a while ago as bug 588.
<DD> is handled by bug 5119; the fix you see for <DD> is a result of David 
Baron's patch for that bug.

Can we mark this as a duplicate of 5119? WORKSFORME is not a very accurate 
resolution.
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.